Unable to type in and click on uiDemo.exe

Hi Guys,

I am working on Level 3 certification in UIpath.

As part of the activity i am not able to type in the user name and password followed by clicking the button on the demo application.

Can anyone help me

Am also facing the same issue. Uidemo app opened. username and password are entered but clicking on login button doesnt do anything. and the workflow stops. any help would be appreciated.

Note: closing the uidemo app and manually opening it and logging in works.

Try with Type Into activities (Username and Secure Password) with attribute click SimulateType and also Login Click activity as well


Also check that you have to run dispatcher first to upload Queue Items to Orchestrator before run Performer main file.

If there is no Queue items in Orchestrator UiDemo App Quits automatically.

i have created the upload queue and ran it. my orchestrator queue has datatable values from dispatcher.
this simulate click and activate are checked. running uidemo_login.xaml works fine. when i run it through the main xaml the login button not working. even when i stop the execution and clicking on login button manually in the uidemo app, am not able to get into details page. Not sure why.

@Jayavenkat can you please share your xaml file here or PM me

UIDemo_login.xaml (9.4 KB)

if the app is opened and i run the above uidemo login it works. but when i run the main xaml it is not going to the details page. even manually when i click login button also it does not work.

@Jayavenkat share you main.xaml and also InitAllAppilications.xaml

Main.xaml (53.7 KB)
InitAllApplications.xaml (7.3 KB)
InitAllSettings.xaml (18.6 KB)


your all files looks fine.

just invoke InitAllSettings.xaml and InitApplications.xaml into _Test.xaml file with assign correct parameters and Run Test.xaml and check wheather DemoApp opens working fine…?

i just figured out the mistake. the password which i typed during the initial prompt was wrong. and it got stored in the credential manager. so it is due to the wrong password passed. now i corrected the password in the credential manager and the app opens perfectly now.

however i face the below error now. can you help with this.

System exception.The values provided for the root activity’s arguments did not satisfy the root activity’s requirements:
‘Process’: The following keys from the input dictionary do not map to arguments and must be removed: in_TransactionItem, in_Config. Please note that argument names are case sensitive.
Parameter name: rootArgumentValues at Source: System.Activities


Can you share your first whole project here??

Hi @Nitin1861

Welcome to the UiPath Forum! :slight_smile:

Sharing of the entire working project would beat the purpose of the learning exercise.

@loginerror Sir I understand but actually I tried from my side very hard to complete whole project but in some cases the errors are coming not able to understand those errors but still trying to resolve them.

Feel free to browse the available topics. For example, if you search by:
Assignment 2

You will have 339 topics about it. It is almost guaranteed that your error message is already discussed in those topics. You can then search by your error message and see what comes up :slight_smile:

1 Like


Same Question, for unknown reason i cant click the login in uiDemo.

The UiDemo works fine , because when i close and then open again , type the username and password manually. it can log on.

UiDemo_login.xaml (9.5 KB)

Can you try with this? UiDemo_login.xaml (8.3 KB)

I just change your selector on the selec button, you trying to get the text while you add to click on the buttom selector.

Tell me if it’s works


Hi Aarivat,

still doesnt work as expected.


Thanks @Jayavenkat. Looking in the editing the credential manager worked for me as well.
For others who have inadvertently typed in an incorrect username/password go to Start > Control Panel > User Accounts> Credential Manager > Edit Generic Credential