Level 3 Lesson 1 issue

Hi. I’m going through the walkthrough of lesson 1 in the Advanced training but I’m struggling to get the robot to recognise the UiDemo.exe login window. Every time I try and get it to log in I get this error:

Attach Window ‘UIDemo.exe UiDemo’: Method not found: ‘UiPath.UiWindow UiPath.IUiNode.GetTopLevelWindow()’.

I tried seeing if it was a selector issue but it says it’s validated. Any attempts to indicate the element also get an error that reads

Method not found: ‘UiPath.UiWindow UiPath.IUiWindow.Minimize()’

Any ideas? I’m completely stumped on this one.

Hi @mcon9102. Hope this finds you well.

Can you post a screenshot of your workflow please.

The workflow itself is a replica of the walkthrough in the PDF. For some reason it can’t find the attached window

did you have UiDemo launched or closed when the workflow ran?

and also show ur selector for the attach window.

UiDemo is open. This is what the selector looks like along with the error when I click “Indicate Element”

try remove cls

Nope. Didn’t work. The selector is valid, so that shouldn’t be a problem. I’m wondering if it’s something to do with the system files deep in the computer, but I’m not experienced enough to know what or how to go about that.

have you tried restarting computer?

I think I worked it out. It’s a compatibility issue. The project files on the training were made for 2018.2 and something has been lost when converting and updating the files. I had a look and other test projects that I have created work perfectly fine. I think creating a brand new project using the REFramework rather than using the files found in Academy should make the error go away.

1 Like

I had similar issue and finally got the solution. Studio got updated automatically in my case. You do not need to create new flow but just go to Manage packages and update all basic packages, for the activity you are faccing issue with, to latest level. It should work. Try restarting studio once if still not working. Hope this helps.

3 Likes

Same issue. Solved it by going to manage packages, clicking on project dependencies, and clicking all the blue up arrows for each dependency. Save, and restart UiPath.