Ui indicated but cant be clicked

hi guys i’m trying to click some ui elements, it can be indicated

but when i use click, it doesnt do anything and eventually it shows error like this

the selector looks like this

any solution ?


In one selector aaname attribute is showing like Trojan.Win32.Trickster.dnr:21 in other it is showing like Trojan.Win32.Trickster.dnr:20. Because of that it is not identifying. Make it dynamic selector by using wild card and then try once. It will work for sure.


hi @lakshman
i tried as you said, but i still encounter the same error

1 Like

Hi @RobertoEwaldo, Remove the url selector use the aaname selector as @lakshman mentioned above. And the Change the click type as Simulate Click.

Also make sure Parentid is stable.

Michael Udhaya

1 Like

hi @Michael_Udhaya, tried as you said and still no luck, and yes parentid is stable

Remove that tag attribute and check once.

Before use click activity check with Highlight activity to check where its indicated?

1 Like

Hi buddy @RobertoEwaldo

–Make sure that the click Activity is within a ATTACH WINDOW Activity
–enable the simulate click property in click Activity
– put aaname like this buddy
aaname = ‘Trojan.Win32.Trickster.dnr:*’
And other attributes been selected looks good

Hope this would help you buddy
Cheers @RobertoEwaldo

1 Like

hi @Michael_Udhaya
the highlight shows it right, but still no luck

hi @Palaniyappan
i tried as you said
but still no luck

Kindly check whether title attribute is dynamic or not
if dynamic change it with wildcard *
and make sure that Simulate click property and waitforready property is set to complete in the click activity
Cheers @RobertoEwaldo

Did that work buddy @RobertoEwaldo

the title is Trojan.Win32.Trickster.dnr: 23, the number is dynamic so i already changed it to *, i also already check the simulate click, but still doesnt work. where is the wait for ready property ?

there’s something i notice the app name in the selector is mmc.exe but actually the app name is something else, i tried to change the app name but when i validate it, it gave me :x: