Highlight is valid but not visible

Hi guys,

i have a trobule about this error in as i mentioned in the title (highlight is valid but not visible). I need the find this strange error.
I have click activity and i did dynamic and Validation is ok. Highlight is ok. but when i start the program it does not click. I have highlighted activity. But for now i commentted. Still not working my click event. I do not get the error message. I have if-else. if element exit then click otherwise show me the error. But program goes to then side.

  • What i’d already tried
    => Delay exist 3sec.
    => SimulateClick ok
    => SendWindowMessage ok
    => Just aaname is controlling no other exist css or html stufs.
    => In UI Explorer i did indicate Anchor.
    For aaname, i’m using variable.
    Why program cannot click the number?

Thanks.

Without highligh i’m getting this error. I try highlight in mouse click activity is ok. but when program runs it happens like that.
=> Click ‘DIV’: Cannot send input to UI element because it is outside of screen bounds.

@yigit.aybey Can you check the below points

  • Did you enable send window messages or simulate. If yes, then disable and run the code and check if the same error coming up
Cannot send input to UI element because it is outside of screen bounds.
  • Take another sequence (since I don’t want to disturb your current code) and use the same click activity there, without dynamic value in aaname. That means just pass some static value and check is it able to click

i did simulate and message but if i use simulate i’m not getting the error message but program does not work either i’m getting different error message you can see the link below.

=> No highlight => Click ‘DIV’: Cannot send input to UI element because it is outside of screen bounds

@yigit.aybey Keep only aaname in the selector and pass some static value instaed of variable and see it is able to click. Disable simulate for now

You static mean , giving integer in manuel like 10?
by the way i have to use variable but for now i can use like what you said.

@yigit.aybey Yes. Just to test bot able to click this way or no

There is a interesting problem happened. The click event does not work in chrome browser but in the ie it works. :sweat_smile:
Is it about uipath chrome extension or cache or smt ?

and also i give the variable again it works again lol

@yigit.aybey Great!!. So is your issue resolved. or do you want to make this happen in chrome as well

I do not want to use ie. I want to make this happen in chrome as well yes

@yigit.aybey Did you try passing some static value like 10 or so instead of passing variable in the aaname and see is it able to perform click in chrome. Also, don’t disturb the current code, take a separate sequence and copy the click activity there, try do these changes and see how it goes

Well this program getting more bizzare lol. What i did. It worked but. I have open browser activity and i did not touch the click event ok. i’ve just changed the open browserType and now it worked. By the way i’ve tried in the chrome all the time i just change the browsertype to ie and then i change the to chrome again and it worked loool. What is the magic here ? :rofl: :sweat_smile: :smile:

I’ve been dealing with this problem since at the beginning of the week omg. srsly. probably it is going to break again i’m not sure but for now it is ok but srsly i did not understand the magic of here?

The error caused by idx="" =>
if i erase or use * the problem occures. this idx changing. Can i control this? or making variable can it be fix i do not know.

you can try with cursor positioning by offset
that may help you