Ui Explorer not loading selectors for Windows Desktop Applications

selector

#1

Hi guys,

We are working to automate workflow for a desktop application. But the problem we are facing is that UI Explorer doesn’t load selectors for Windows Desktop Applications such as Task Scheduler(“Type Into”
for Creating a new Task), Event Viewer, or any custom VB6 desktop Application.
On other hand, it works fine for notepad, any browser, etc.

This has been tried both in 2018.1.1 and 2018.2.3 version.

What could be the possible issue? Can someone please help, it is urgent.
PS: all of it works on one of my colleague’s machine but few of us are stuck on this issue.

PFB:
Trying to get selector for Name field. Ui Explorer is blank.


Administrative Command Prompt
#2

@badita Can you or someone from @uipath please help on this


#3

Hi @Natasha_Gandhi

It seems like you can find the selector manually, but it still will not work in UiPath afterwards. Strange.

To display the selector you have to right click the node and click on “Set as Target Element”


#4

@Natasha_Gandhi
Run UiPath Studio as Administrator and then u can get selector in such scenarios.


#5

Yes, you are correct it could be done manually, but later activities of UiPath won’t work such as Type Into or Get Text etc,.


#6

Thank you! This worked our for us. It runs as Administrator and loads up the selectors for WIndows Applications as well as the custom VB6 Desktop Application.


#7

Hi @abhyudai_munna
What is the difference between running in administrative mode and not running uipath in administrative mode


#8

Hi @pruthvisiddhartha

The problem is that the target application runs as admin so UiExplorer cannot inject into target process (because it has lower privileges). Even if you have a selector it is not guaranteed to work when running the automation (for the same reasons).