UiPath Studio needs to be run as an administrator


#1

@adrian

There are times when UiPath Studio does not hook into the application and UiPath Studio needs to be run as an administrator. And it so happens that the user does not have the access to run UiPath as an administrator. And if they cannot run it as an admin, it so happens that the selectors cannot be found and they need to do UI and Image Automation. Is there any work around to this issue? Below is the screenshot for the same:-

Thanks & Regards,
Sachin


#2

The problem is that the target application runs as admin so UiExplorer cannot inject into target process (because it has lower privileges). Even if you have a selector it is not guaranteed to work when running the automation (for the same reasons).

It could work only if you can get a selector containing only tags and use only attributes that do not require injection (aaname is not ok)

Besides image automation one can try keyboard automation (tabs, enter, arrow keys, etc).


#3

Hi adrian,

Is the problem described in this post solved?

I’m facing a similar issue, that even I set Studio to always run as admin, and it can find some selectors, for instance using “click” or “activate” activities.

But still, when I run the process, none of them can actually find the selector.

Is there a walkaround?
Or, is it possible to lower the priviliges of target program?

Thanks a lot!


#4

Some additional information.

I’ve tested the same software with UiPath 2017 on another computer of mine, turns out that the 2017 version doesn’t have this issue. Running 2017 as administrator can find selector and perform while running the script.

So, now I’m thinking maybe the 2018 upgrade is the reason.


#5

i don’t exactly understand the issue. 2017 version can get selector while running with no elevation and 2018 can get selectors only when running as admin?

Can you perform the tests on the same machine to confirm? (maybe the security settings on your machines are different)


#6

Thanks for the response
I’ve created a new topic on this matter.

So, if I would like to try the 2017CE, where can I get it?
Thanks!


#7

Right. So, got the install file from another computer.
And I can confirm that 2017CE on both computers don’t have this issue.


#8

Hi,

We are running an application using elevated rights (“as local admin”). It’s a windows application. UiPath was not able to recognize any UI elements initially but when we ran UiPath as administrator, it is able to recognize UI elements but it’s still failing for each activity while running the workflow.

Is there a solution to this? Ideally, running UiPath as administrator should work but why is it still failing even after generating the selectors?

Thanks & Regards!