Type into "Save as dialog" does not work with simulate

Hello,

I’m downloading a file from a website, which i want to save to a specific folder. I’m using “Type into” and simulate. The path given is this: “C:\Users\mds\Documents” + variable with filename.

This types it in correctly, however it doesnt actually save to the path above. I found two workarounds:

  • Enable file extensions in Windows
  • Use hardware events instead of simulate

As you can see, it types it in fine. The funny thing is, If i stop the bot, copy the filepath the bot wrote, and paste it, it saves without any issues.

It seems somehow Windows doesn’t really recognize the bot “typing”.

Does anyone have any solutions to this issue, besides the workarounds i found?

2 Likes

Hi @MaxDS1 ,
How about using hotkeys . Did u give a try

Hi

In type into activity we can see a property called DelayBetweenKeys
Put some timestamp for that like 1000

And then give a try

Cheers @MaxDS1

Hi @MaxDS1

If simulate is not working then kindly ignore that property and proceed with type into

Also in properties there is something called delay between keys

Go with 800 ms

Kindly increase that so that it doesn’t miss out any word in dialog box

Thanks

can you try set text

DelayBetweenKeys is only for hardware events. I tried 1 second delay both before and after - issue persist.

Issue persist with set text. I have not tried with hotkeys though.

1 Like

Fine

Give a try with hot keys with below steps

  1. Use a set to clipboard activity and pass your input string as value

  2. Then use a send hot key activity and mention the key as ctrl+v and indicate the element where you want to type

This will paste the value from clipboard

Cheers @MaxDS1

1 Like

hey

did you try using the modern activities? for this kind of situations is more reliable.

regards!

@MaxDS1 Did you try with set text activity

Check with this one and let us know if you are facing any further issue

@MaxDS1

This worked perfectly.

Any idea why we need this “workaround”? Why does the “Type into” not work?

Yeah. Same issue.

Yeah, I’m using modern activities :slight_smile:

well, did you try with hardware events?

Yeah. No issues with hardware events. Only with simulate.

But it works with hotkeys and copy+paste. I was just curious as to why a simple “Type into” with simulate did not work.

1 Like

It might be because of the GUI elements of that field
And it’s not that all application will accept simulate type
Only few will take and others won’t take
Simulate option effectiveness depends on the application which we are using. Some applications we could see the issue you mentioned like partially it works (some times it will do our stuff and some times not). For some applications it will not allow us to do simulate and allows only with driver

Cheers @MaxDS1

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.