Issue : How To Save a File From Browser using Type Into And Simulate Type

Hello All

I’m not sure if this is a bug or not, but both in IE and Chrome my observation is as follows:
If I use Type Into Activity and Type the full path while saving the file in download file save location while the Simulate Type is unchecked, it works perfectly

However If i repeat the above process with simulate type checked the file is saved as default filename

Please note , that click before typing, empty field and activate are all checked in the properties in both cases

Any suggestions on how to solve this? is it actually a bug? @loginerror any advise?

Hi @neonova

Just a suggestion,

Give some delay (like 1 or 2 seconds) after type the path…

And are you giving enter in the type into after type the file path or click save button, I would recommend to click save button instead of type enter after type the filepath.


Have tried delay and both enter startergy and clicking save button. Got the same results for all cases. The problem seems to be that simulate type simply pastes the entire data without remove the previous data.

I have a temporary solution, where If i send a backspace using send keys to the file name before the simulate type, it saves using the proper path even with simulate path. But I’m still not sure why simulate type doesn’t work properly? (it doesn’t remove/empty the filename fields despite the properties being checked)