Simulate type doesn't work properly

test.xaml (9.3 KB)

Hi, I’m facing issues with simulate type into activity. I really wanted to speed up my robot, but it doesn’t seem to want to fast type path. I attached testing workflow, I’ve tried to put Type Into activity inside/outside attach window, inside/outside attach browser, I’ve also tried SendWindowMessages option as well as SimulateType.
Nothing of these seems to work, and robot is typing path character by character, which is really slow.
I’ve read similar topics at forum, but seen no results.
Why it works fine with some popping windows, and with other does not? Could anyone answer some of these questions? I would appreciate any help in this topic :slight_smile:

1 Like

Simulate type into works best with Web applications. For any other application, it’s better to use the default type as that’s said to be 100% compatible.

Btw, I can’t open your workflow at the moment so I’ll ask you this. Are you trying to open a file or any application by putting the path onto the pop up window? If yes, then there might be some other way to do so.

Yes, I’m trying to pass path to file in pop up window, to open a file.

On the web page, I’m clicking button to upload some file, and then pop up window appear to select file. And in this window I’m passing path with Type Into activity.

Do you JUST want to upload the file or do you need to open it as well?

Just want to upload it, it’s an image. I’m selecting path to this file in pop up window with typing, but very slowly. Wondering how to speed it up.

If type into simulate type doesn’t work, the next best thing, if i’m not wrong, is the default method. However, if you want to speed up, you can try this:

  1. Use a notepad file and use type into simulate type on it instead.
  2. Send hotkeys Ctrl+a and Ctrl+c on the notepad.
  3. On your pop up’s text field, send hotkey “ctrl+v”

This is what I can think of as of now. Try this and let me know if it works.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.