"Type Into" Not Executing Properly

activities
studio
debug

#1

So… I am trying to save a file using internet explorer. I had this automation working, suddenly I resized the window and it stopped working.

I had to go back, review my code and reconfigure the selector and options of the “Type Into” activity. I turned on “Activate” and “Click Before Typing”, which I am not even sure if they work, because at one point I had to manually implement a click activity, since the “Click Before Typing” was not being executed. It was now working again, it successfully executed a couple of times.

Then I went back to execute the overall automation and it is no longer working. It opens the windows save as dialogue window and it skips the “Type Into” activity. How is this even possible? This makes no sense, it is hard to reproduce and random. I really need some help on this. I have been stuck with this crap for days and I have a deadline to respect.

Save%20As%20Dialogue


#2

Hello @Testing360, sorry for asking for something not directly related,
but are you trying to type in the address bar, not the File name bar?


#3

yes address because I need to choose the filepath where to save the file to


#4

@Testing360,

If that’s the sole purpose, I think you can do it effectively by typing the path in the File Name bar too.
Sometimes the typing got weird, so when typing in the File Name bar, better uncheck the Simulate Type option.


#5

@Testing360,
*In The screenshots attached above,The saveas Window has some additional background.Try to remove the background and try to attach only the window of SaveAs
*Type into filename has some text,Check the selector whether it contains this text.If Yes then change Change the selector to Dynamic and then try once and let me Know whether it has solved ur issue


#6

I solved it by changing the actions. Instead of trying to click it, I use keyboard keys that interact with the window and allow me to select the filepath entry field. Then I instructed the robot to simply write the filepath, press enter and it is done :slight_smile: It was a hard one to solve… :confused:


#7

By the way, you can use the full filepath in the Filename field instead of just the filename. That’s how I have been doing it for all Save Dialogue windows. This way you don’t need to be on the correct directory first.