Type into just removes what it typed before

Hi everyone,

I am new to Uipath. Currently, I am trying to fill an online form with details in csv using For Each Row Activity. I have an issue with Type Into where the activity actually gets data from the row in my loop and type into the field in browser. However, after type in, it is also removing what it typed.

I am not able to share the data but what I want to share is the type into just removes what it typed which I cant find that kind of issue in our forum. Appreciate if anyone has an idea.


Hello @laura.tran610

This is weird… May i know this. You typed something earlier and again when you do the type into, it is overwriting what you wrote previously… is that the issue?

Or is it deleting everything you typed and the text area has nothing after clearing?


You can try Type into activity keeping delay between Keys


You can try with Set Text Activity also

Mark as solution if this helps


Hi Lahiru,

I used type into to add data from csv to the online form. I can see it’s inserting data but its deleting what it has just typed. So at the end, there is nothing.

Do you have any idea?


Thanks for your help. I tried both suggestions but they did not work. Text still is deleted after it got typed in.

Hi @laura.tran610,

Some text field contain data validation point so try sending hotkey(enter, tab ) with your input

Hi Saman, thanks yes, used all but still did not work

can you share a screenshot

@laura.tran610 Try filling up of only one or two fields of Data and check if that Data is Stored or becomes empty at the end for Submission.

Also Can we get a Screenshot of the Property Panel of the Type Into Activity?

Hey @laura.tran610

Probably i believe, your text box might have auto fill data.

Possible Solutions

  1. Disable autofill option in chrome.
  2. use a tab after writing text using type into

Hope this will help you.


I do not know if this is still an open issue for you but I faced something similar. I had to make a data entry into a webpage and once the bot finished writing the value, it would simply revert to its initial value (as if the typing was not registered at all).

The reason I figured was the form was a part of a web plugin and I was doing this activity through Chrome. After trying multiple options through properties of “typeinto” I thought of trying with internet explorer instead of Chrome.

Using IE is worked like a charm.

Hence, I would suggest that when those forms are not a part of the web page directly but available as a web part / plugin, try changing your browser as it worked in my case.
Hope it helps.

Thank you.