Type domain\username - issue with slash

Hi

I am having an issue trying to type a domain\username into a web page login, when the process runs its strips out the \ making the login invalid.

Does anyone know how to force the backslash.

Thanks

1 Like

It should work. Try in notepad type “user\domain”. Does that application accept typing “”?

Hi Mihai

It does work in notepad and the application (which is a small web app) does accept it as you can/have to type it manually to access it, I can even paste the domain\username into the field, but getting the UIPath to type it in always strips out the \

Sorted, used hardware events and a delay between keystrokes and everything works

Hi Dave,

Would you mind sharing the misbehaving setup?

I’ve experienced similar issue with SendWindowMessages method that’s now waiting to be fixed (it gives result as if you’d type on a keyboard with broken shift and alt) and was wondering if it’s the same cause or I should worry about something else too.

Ah, yes, the issue was Simulate Type.

There are 3 typing methods:

simulate type
window messages
hardware events
The simulate type can’t send special characters like [Enter], [Alt] or other hotkeys.

Regarding the Window Messages there is one thing you should be aware when working with Send Hotkey activity. I’ve noticed that sending “Alt+S” will be interpreted as “Alt+Shift+s”. Thus it needs to be configured as “Alt+s”.

Hi Mihai,

No, it was a bug with SendWindowMessages - it doesn’t correctly send uppercase (or anything that you need to type with shift or alt). I’ts scheduled for a fix (still present in newest version), but I was wondering if Dave’s issue was the same or something else.

I’m (since 3 weeks) aware that simulateType does not send special keys, but that was not it. The SendHotkey thing was also known to our team and from our perspective that’s working as intended.

I was told on the support page

“Please try to use hardware events instead of API (Simulate type) and also you can add a slight delay between keys to see how it behaves”

This I did and it worked.

Dave

Hello!

I am trying to input some values in a web based system, and I am using SendWindowsMessages.
The problem is that the slash character “/” is being typed as “q”.
As I am trying to input a URL, the result is incorrect: http:qqwww.alfabetagama.comqproduct

I made a test xaml to input the same text into Notepad++ using SendWindowsMessages, and i get the same result.

Does anyone have an idea how to solve this?

(The SimulateType doesn’t work for unknown reason, so I need SendWindowsMessages to work in background).

Thanks for any help!

1 Like

Hello,
Is there a correction or a workaround to the problem?
Thank you in advance,

SimulateType and Type : sDomain+“double”+sUsername

Hi:

I solved the issue writing the following:

“first_string’[k(back)]BACKSLASH’[k(back)]second_string”

Did you try to escape the backslash? And maybe in the following task replace it again by the String function replace?