Trying to run unattended robot using 'Community Edition' ... with no luck :(

Hi,

TLDR - Trying to run unattended robot using ‘Community Edition’ … with no luck :frowning:

We’ve recently started using UiPath, running some simple robots using UiRobot.exe and a xaml file.
Note: We installed the Community Edition ‘UiPathStudioSetup.exe’.

Everything worked as expected so long as we we’re logged onto the machine running the robot (i.e. attended).
If we disconnect from an RDP session the robot ‘times out’ …

RemoteException wrapping UiPath.Core.ElementOperationException: Timeout reached.  
---> RemoteException wrapping System.Runtime.InteropServices.COMException: Timeout reached

After reading the docs again …
We re-installed (using ‘UiPathStudio.msi’) to get the UiRobot windows service (by default running as SYSTEMACCOUNT)

… BUT we’re getting the same behaviour.

We’ve also tried running the UiRobot windows service as an admin account but we get a different error

Exception: Could not start executor. 
A required privilege is not held by the client. 
(Exception from HRESULT: 0x80070522)

NOTE: We’ve checked and the admin user has the following (as per docs)
- Access this computer from the network
- Allow log on locally
- Allow log on through Remote Desktop Services

According to docs ‘Community Edition’ can run 1 unattended robot.
(https://www.uipath.com/start-trial)

Or have we misunderstood this ?

Has anyone got this working or can point us in the direction of the bit of docs we’ve overlooked ?

Thanks in advance

Cheers,
Shaun

You could try to login as the account you want to run the automation and see if the automation will run at all. This will determine if the issue is with the user account itself or a configuration with the orchestrator or robot.

To do this:

  1. Make sure the robot is listed as online in the orchestrator.
  2. Change your robot setting in orchestrator to “Login To Console” --> No (This will allow you to login and watch the automation run) image
  3. Login to the machine using the robot account
  4. Start the job from orchestrator.

Thanks for quick reply/help

Do we need to use orchestrator?
I thought you could run a file using uirobot locally. To use unattended should we be using orchestrator ?

We haven’t had to setup orchestrator thus far… have we somehow missed a step?

Hi @CodeMonkey_UK,

Orchestrator is required to execute unattended robot.

You can use community orchestrator if you haven’t setup one.

@CodeMonkey_UK

The UiRobot tool uses a connection with Orchestrator to run processes in attended mode. For unattended the orchestrator communicates directly with the machine using a robot service that runs in the background of the machine.

I’m not as familar with Community Edition, but I believe you can get a small orchestrator for free by logging in here:
https://platform.uipath.com/
Login with your community email and password (if you have one).

Thanks will look again tomorrow and feedback either way

Hi @CodeMonkey_UK - Are you able to see “Connected Licensed” like this.
image

If yes and still it is not working then maybe Firewall or Antivirus(mainly Avast) blocking the connection. Try after disabling that.

Hope it will help you.
Best!!
Anmol

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.