Getting error message 'Info: Could not start executor. Creating user session timed out.' since upgrading Robots to 2023.4.2

Hello,

Recently we have upgraded our UiPath unattended robots from version 2021.10.5 to version 2023.4.2, and we are experiencing intermittent issue whereby a job will fault after trying to create/imitate the RDP session on the unattended server jobs are being created via the cloud Orchestrator.

Info: Could not start executor. Creating user session timed out.
System.Exception: Could not start executor. Creating user session timed out.

We did not experience this for 2+ years of running on version 2021.10.5, and we have 1 server which is still running version 2021.10.5 and this is the only server which does not have faulted jobs over the past 3 months.

We have worked with UiPath technical support but they have been unable to identify the root cause.

I have tried the usual increasing the UiPath_Timeout, making sure robot are set to logon to console false etc, and these servers are the same ones which were running processes on the 2021.10.5 studio of the past 5 months, so no setting have been changed regarding robot Orchestrator settings etc.

I wondered if anyone else had experienced anything similar when attempting to run Unattended processes on 2023.4.2 robots?

1 Like

Try these:

· Go to Control Panel → Programs → Apps and Features → Uninstall the UiPath Platform Installer (if exists) and UiPath Studio

After the UiPath Studio/Robot uninstallation, delete the below folders if exists:

· The settings in the folders %PROGRAMDATA%\UiPath, %LOCALAPPDATA%\UiPath, and %APPDATA%\UiPath
· The packages folder %USERPROFILE%.nuget\packages
· The NuGet cache folder %LOCALAPPDATA%\NuGet\v3-cache
· The Assistant processes folder in the Windows Start menu %APPDATA%\Microsoft\Windows\Start Menu\Programs\UiPath Assistant Automations
· The content from the %temp% folder
Install again the UiPath Studio/Robot using this installer https://download.uipath.com/versions/23.4.3/UiPathStudio.msi
· Make sure that you followed the prerequisites from https://docs.uipath.com/robot/standalone/2023.4/user-guide/installing-the-robot
· Try to set the UiPath_SESSION_TIMEOUT System Environment variable to 500 and restart the UiPath Robot service.

1 Like

@marian.platonov

Where do we go to change this setting?

Try to set the UiPath_SESSION_TIMEOUT System Environment variable to 500 and restart the UiPath Robot service.

1 Like

Run the below command in a powershell.exe console as Administrator:

[Environment]::SetEnvironmentVariable("UiPath_SESSION_TIMEOUT", "500", "Machine")

or

Manually in Environment Variables

Same problem after updating from 2022.4 to 2023.10
UiPath_SESSION_TIMEOUT is set to 500 but didn’t help.

Any other suggestions?