Triggered jobs doesn’t run on unattened VM when my Remote Desktop connection is disconnected or VM is locked

Triggered jobs doesn’t run on unattened VM when my Remote Desktop connection is disconnected or VM is locked(Win+L)- Community Edition

Note: Its working fine when minimized or logged in state.

As per the below post : It is a limitation of Community Edition version and install Uipath Asssitant using EE msi package.

How to uninstall Uipath Assistant (Community Edition) and Install Uipath Assistant (EE Version)? or Do we have any other way to make to robot to work when the system is locked or RDP is disconnected?

1 Like

Hi

Did we try installing remote runtime extension

You can get it via our Automation Cloud Resource Center:
https://cloud.uipath.com/portal_/resourceCenter

Cheers @Sathish_Kumar_S


Link taking to orchestrator page and i don’t see the option to download the remote runtime extension for Windows remote desktop…

1 Like

Hey @Sathish_Kumar_S

Hope you are doing good

This is a bit common issue, I hope you are facing the same

You should have installed the bot in service mode, but community edition by default allows you to run only in user-mode.

So only enterprise MSI will give that cushion with service mode :slight_smile:

Thanks
#nK

Thank you Nithin…

So i can install ONLY uipath assistance using Enterprise MSI installer and keep using community edition Studio?

If i install only uipath assistance.Will uipath assistance also will expire after 60 days?

1 Like

Yes if you go with enterprise trial you will get for 60days.

#nK

Since i am planning to install ONLY uipath assistant using EE MSI… and keep using CE license for Studio.

Will Uipath assistant expire after 60 days?

1 Like

No it may not. But it’s still user mode and will have disconnection issues.

I have installed only uipath assistance (service mode) using EE MSI and Now system is unlocked automatically and completed the process

1 Like

Try logging off the user and then disconnect. Then try triggering unattended process.

Hi @Sathish_Kumar_S,

Try the suggested solution from this thread :
Take screenshot fails in unattended mode when RDP disconnects - Help / Robot - UiPath Community Forum

The cause of this behaviour is Robot Settings (Login to console) : Robot Settings (uipath.com)

@Sathish_Kumar_S

Check whether the robot license is Unattended?

Thanks

If you manually log into the VM, when you’re done you must manually LOG OUT. Don’t disconnect, don’t lock, don’t just walk away and let the connection time out. LOG OUT. Then run your unattended jobs.