Try Catch and Throw activities

Hi UiPath

When I surround a Throw activity in try block of try catch, it is executing correctly by going into the catch block. If I add any other activity like Write Line before Throw in try block, execution is ending at try block with Throw error msg and not going to catch. This scenario is observed even after removing all the activities before the Throw activity. I had to delete the sequence to get the initial expected scenario.

I’m sure this is not the expected scenario with Try Catch. Hope to see some more information on this

this is after removing Write Line activity, not moving to catch block



Which version are you testing?
I rebuilt the project in version 2021.10.4 and it worked fine.
It showed the message of the first Write Line, then presented the exception in Throw, went to Catch and showed the message of the second Write Line.
Here is a print of the output screen.

You should move this to Help instead of Feedback. Feedback is for things like feature requests, etc.

I’m using 2021.10.4 and the packages are as below

are you using same versions of the packages ?

Mine are in this version.

This is weird !!
I tried by launching a new process and recreated same sequence and this time it worked !!!

@tainan.ramos thanks for your quick analysis

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.