RDP Disconnected Error

Hello UI Developers,

I am facing an issue that by Scheduled jobs doesn’t run when my Remote Desktop connection is disconnected or locked(Win+L). Note: Its working fine when minimized or logged in state.

I tried to search this issue on ongoing threads but no solution worked yet. I read that there’s something that disables UI object when you disconnect RDP. But no any specific solution to allow UI robot to start his own UI session.

Can you please provide a solution so that robot can work even if I disconnect my RDP (Remote Desktop Protocol) session?

A UI Path Developer.


Can Do! Are you using an attended license or an unattended license? Also are you using the Orchestrator to schedule the jobs or another way (I see you mentioned UiRobot.exe)?

I am using a community version with Unattended Robot. I am using Orchestrator to run Ui jobs.

Note: I just now realized that I use Citrix to connect to remotely not sure if Citrix connection is different than Remote Desktop Connection App.

Lets try this-

Connect to your machine using Citrix
Trigger a job on the orchestrator to the robot on that machine
Check to see if the session disconnects after starting the job.

Including this too just in case-

I am the Administrator myself for that Remote Desktop. Still do I have to setup a user of myself(The Administrator) to RDP users list?

I did all the above setup and ran the Job; But the Robot doesn’t disconnects my current session instead uses my same current session.

interesting! so you are able to see the bot take over and start the job and still have the ability to watch the desktop as its running? Probobly a Remote Desktop/ Citrix thing. I’d like to see what happens to the robot status in Orchestrator when you close out of Citrix.

Then job fails and gives error that Desktop has been disconnected. Doesn’t the robot creates a session for itself when I disconnect My session? or is it that it requires an active session and use it run a job.

Currently I was reading below remote session settings which I believe could help if UI robot cannot create a session on server:

But it would be better if UI Robot creates a session of its own.

@Forum_Staff Can you please let me know if this is an Identified issue and you have any plans in next release or something? I have tried all the solutions, even read the Interactive Session posts and all I conclude is My Robot is unable to create its own session and run a job when RDP is disconnected.

A tons of Topics on this error with Majority with No solutions!

@Ravi_Chotaliya Could you check to see if you get the same error if you trigger the robot from the orchestrator while you are not connected to it with citrix. It sounds like you are triggering the bot from orchestrator, watching it run in citrix, disconnecting from citrix, then getting the error. With a regular remote desktop connection you would typically get kicked out if the bot started up.

I’m hoping that you have better results with this if you try to run the bot without being connected first, then watching the status in orchestrator to see if it errors out. Hoping this works!

Hi @Ravi_Chotaliya,
Please observe that in case of Community Edition the Robot service is working under User Thread:
So if you have logged off or session is locked this service will be not responsive. It’s the main reason and limitation of CE version. You can install Robot from EE msi package so your service will be “System” based.

1 Like

Yes I found now that UI path services are working under my User tray. Now for your Solution I have few questions:

  1. Is the Robot from Enterprise Edition version Payable? (Do I need to buy EE licence?)
  2. Will the Robot from EE version be compatible with Community version?
  3. Do I need to delete the community version Robot running under my user tray when I install EE version Robot?
  1. Robot should work just like it is
  2. Should work but there will be other problem. Community Edition is updating automatically. Robot installed from MSI will stay in the same version constantly so you need to update working path to robot on every update.
  3. I think so.

Please remember that it’s only a hint. It’s not by any way official UiPath solution. Normally the solution for this is to just buy Enterprise Edition and work with it.

OK so overall, we can say that this issue is working fine in EE version of UI Path, but will remain an issue with Community Edition.

As robot services works under User tray for community edition and not system tray like EE version.

I wouldn’t call it an issue. With Studio Community Edition you have by default Robot and one attended robot type. Only Community Orchestrator offers more robot licence types but those (like unattended one) will not work fully with Studio EE because of limitation.

Ok so can we mark solution as:

The Community Version’s Unattended Robot won’t work if the RDP User session is ended by locking screen, Disconnecting RDP, or logging off.

1 Like

For sure will not work with session which is logged of. For the rest (I’m not 100% sure) if you are running on Windows Server there might be the way to keep all users services up in the background.

1 Like

Sure! I’ll google in that way. Incase there’s a option to keep User Services running.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.