Trigger wont start because I have a pending job

Hey guys. I am testing with triggers right now. I set up a trigger, but got a message, that It can’t start because I have a pending job.

Folder povilas********* workspace: #trigger Skrapperis for #process Save top 10 search results in an Excel file could not create jobs. The robots already have pending jobs for this Process (#1670)

Hello @Povilas_Jonikas

Please check whether any pending jobs are there allocated to the robot. If any you need to first complete that else you can stop it.

Thanks

Go to the Jobs Tab and see the status of the Job.

Thanks

1 Like

Ok, found one pending job. Killed the procces and now wating for the trigger to start. Ill let you know how it went, thanks :slight_smile:

HI @Povilas_Jonikas

Check out this document

Regards
Gokul

1 Like

I found the problem, but don’t know how to solve it. So the trigger puts the job into pending status, and nothing happens. My trigger is setup to repeat every 10 minutes. The first time it puts the job in pending, then after 10 minutes I get an error, that there is a job pending.

Thanks @Gokul001, but i’ve read it already, but couldn’t find no info on it

Hi @Povilas_Jonikas

Let saw like this If the process 1 is running. The next trigger will be in the pending state till the process 1 finished.

After completing the process 1, the next trigger will be started.

Does the process run successful in the studio?

Can you share the screenshot?

Check out the video link

Regards
Gokul

Hi @Povilas_Jonikas

So second part is expected because when a job is already in pending one more job to same machine with same bot cannot be created

Coming to the first part is there any other robot running on the machine or is the robot disconnected or busy? You can check the state in robots menu

You can confirm if you have given domain/username

Cheers

Can you please confirm the jobs are executing as expected? If job is not all executing and always going to the pending state, you need to check whether the robot is properly connected to the orchestrator or not.

Thanks

@Povilas_Jonikas

Can chck the below video.

Thanks