Jobs are being in Pending!

Hi there,

I have a problem with jobs triggers !! I have more than 10 Triggers with Queues > the trigger is triggered when new item is being added …
Now all the jobs is being pending !!! items added successfully to the queues !!

I cant understand why now all jobs are being in pending status even if I ran it manually :sob:.

Please , any suggestions! I will be appreciated :cry: .


The Jobs will go in Pending state when the robot is busy with any other job or if no license allocated to that robot.

Check on these two things, also check the Queueitem status in the queue.

No its not busy…

For now I used Enterprise edition trail !! does it harmful my license was with community !! also I triggered 13 jobs ( processes ) from postman by adding new items ! just only 3 processes ran but the other got in pending!!! I triad to run it manually but also got to pending!!! now all the processes are being pending !!!

Noted that I have one template machine with one robot account Unattended.

Hi ,

Check license is available for that BOT.


Hi ,

Please check is there any process long running may be because of that long running process other jobs are in pending state. Thanks


with community edition it was 100% !!! It seems that I cant use license!!

there no process is running !!

Create new machine template assign the license and connect the UiPath assistant. It will work.


nothing worked !!! :sob:

Share your machine configuration screenshot details and License page also

I solved the problem with deleting my machine template then re-created it and allocate the license again…

Thanks to you all :pray:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.