Time out reached for unattended bot

HI , I am running my automation on a remote machine by remote desktop connection. The issue is that automation is working perfectly in attended mode i.e. via studio but when I close rdp , I start getting time out errors. According to my analysis , when I close rdp session , remote machine gets auto locked and therefore , these errors start occurring. What is the way around here?
My simulate clicks and window messages are enables but for citrix image automation that is not working at all and throws error that simulate click cannot be used
@loginerror @JuveriaSiddiqui @zspilman @MVP2021 @Pravin_Patil1 @Forum_Staff

You are running it from the orchestrator or you are running it manually from the machine and then disconnecting the rdp?

I tried both ways but it didnot work

This will not work definitely and also not good practice.

In other scenario, running it from Orch.

When you say timeout reached. Is it after performing some actions or at start only?

If it is after performing some actions then is it every time at same activity or random?

So , timeout error is on same activity everytime. That is a click activity from UIAutomation Next package. Input method is hardware events because citrix app doesnot support simulate click

Would you mind screenshot of activity with property panel?

Are using Computer vision to perform these actions?

here is it

. For this one not using computer vision but computer vision activities are breaking also if I comment this activity to check them

Can you take this activity in separate attach window and then add try catch to this activity and in catch try to click same with click text activity

"Text not found " error

  1. First try to scrap the screen using screen scraping and see what text is comin and pass the same text.
  2. If text is not coming correctly try to scrape using ocr and then use click ocr text activity

For click ocr text , I get same error that window messages are not supported for this app

Don’t use windows message property and make sure it is in attach window…Add delay before click 3 sec…

Worked from studio but same error in unattended mode , time out reached

Are you taking screenshots of the window when an error is thrown?

I think the problem is not with that button click and that option is not loaded at all…Because of the previous action not performed…

yeah , leaving previous window opened . Screenshot is throwing this error
Take screenshot: System.ComponentModel.Win32Exception (0x80004005): The handle is invalid at System.Drawing.Graphics.CopyFromScreen(Int32 sourceX,

I suggested possible ways without image click but this issue resolution need more ways and tries…

Just focus on taking that required window in focus and add proper delay to load the window properly…

Okay , does cv activities work in unattended mode?

Yes. As per my knowledge there is no limitation with robot mode…

I’m sure CV scope will be helpful in this case

1 Like

okay let me try that out