The system cannot find the file specified

Hi All,

I am completely new to UiPath and I’m trying to learn automate very basic tasks as an amateur.

I had come across this issue, where my intention is to retrieve a small dataset from a website, save it in my local drive and open it. I was almost successful, but I got the following error.

I checked running the file through CMD prompt, which opened, however, didn’t open when I tried it through UiPath.


Can somebody advise to correct this ?

Harish S

Hi @Harish_Sundar

Welcome to forum

Can u give more information on how u ipened the file etc via screenshots etc ?

Before you open that file you can have one check on fileexists/PathExists, and also please make sure you have used complete path to open the file.
from CMD have you used relative path to open the file?

Hi Nived,

Thanks for the warm welcome.

I tried opening following link through CMD prompt - “C:\Users\Harish\Downloads\TestData.xlsx”

When I use the same link in UI path, I get the aforesaid error.

S. Harish

Hi Divya,

Following is the path Ive used/ pasted in UIpath - “C:\Users\Harish\Downloads\TestData.xlsx”

Also, the same path is what Id used in Run command too, to check if the document opened

if it is an excel file why you have to open it?
you can read that excel file and perform any operations needed using excel application scope and excel activities.

Hi @Harish_Sundar
I tried to open the excel file using start process activity. It was working fine

Please check whether the filepath is correctly entered or not

Nived N
Happy Automation