Why am I getting "The System cannot find the file specified"?

I am using Start Process activity, and I am giving the file name as a variable. It stores a string of the full path to the file, and that file ACTUALLY EXISTS.
However, when I run the program, I get “The system cannot find the file specified” error!

Btw, I have a variable named in_FilePath as one of the incoming arguments. And I have given it a default value, by entering the full file path in the “Default value” or Arguments table.

Why am I getting this error, when the file does exist, and the file path is correct?

Another thing, I just used Path Exists activity, and I did the same, but I am getting false!! This is very frustrating… What is wrong?

Can you start process from Cmd manually?


Yah Start process should work if the file path is correct
–Make sure that the file path exists and what exists is correct…use run command in start and paste that string value and run manually, check whether the file opens or not buddy
–check whether the file at the last in the path has some extension in it like .pdf .xlsx .docs .exe like that

Kindly try this and let know whether this works or not
This can be solved buddy
Cheers @tomato25

1 Like

Okay before trying to open the file from cmd, I listed all files, and realized that it had double extensions. Instead of myFile.xlsx, the file was stored as myFile.xlsx.xlsx.

Thank you guys!

My suggestion would be enable show extension in Explorer so you can Check quickly if your files are OK :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.