The request was canceled due to the configured HttpClient.Timeout of 30 seconds elapsing

Hello everyone,
I’m having trouble connecting after my Windows server reboots.

  • Robot (Unattended bot) (Window server 2022)
  • UiPath Cloud

I configure this proxy follow before rebooting my Windows server
(Redirecting Robots through a Proxy Server)


Please sign in to the orchestrator to retrieve the license

And I hope your proxy connection settings are proper


How to retrieve the license ?
in my opinion, I have a license. below these


On the UiPath assistant you have an option to sign in please click sign in and provide the credentials.

And i hope you have assigned license to your machine /user


I think the bot should connect rather than sign in on the UiPath assistant.
And i assigned license to my machine.


You should sign in once…else how bot would get the creds? …this is like linking your bot to orchestrator…once you sign in it links


Nothing happened when I clicked sign in on the UiPath assistance, indicating the same problem.


When you hit sign in did it open your orchestrator


I try install UiPath in the new VM but the issue still getting same error

Try adding in the System environment variables these values:

http_proxy: your_proxy
https_proxy: your_proxy

Then restart the UiPath Robot service or machine in case you don’t have Administrator rights, then in UiPath Assistant try again to Sign in.

If it doesn’t work, remove those System environment variables

1 Like

I tried your method, but it did not solve the problem.

Ok, provide these details:

  1. Installed robot version?
  2. What license you are trying to use from Orchestrator (Unattended or Automation Developer - Named User)?
  3. Do you have a proxy?
    Provide a screenshot from Start → Internet Options → Connections → LAN settings
    Provide a screenshot from C:\Program Files\UiPath\Studio\UiPath.config
  4. How many Robot versions do you have in Control Panel? Provide a screenshot from Control Panel → Programs and Features → search by Publisher UiPath
  5. Do you install the Robot in Service mode? You can check it by opening services.msc and trying to find UiPath Robot
  6. How you configured your robot in Orchestrator? Provide the attended and unattended setup screenshots.
  7. For connection you are using a Machine key from a Machine Template or from a Standard Machine?
  8. Provide a screenshot from Orchestrator → Tenant → Settings → Robot Security
  9. Did you check internally this documentation in advance? Configuring your firewall for Automation Cloud

@Wirit_Panrit it seems that you don’t have unattended licenses. When connecting Robots with machine key, it needs an unattended license. If you refer to the NonProduction license, then you only have one that is already consumed.


1 Like