The Process cannot access the file because its being used by another process "pdf" file


I have a use case where I have to download a pdf file and check if I need the file or not.

If I dont need the file, I delete the file in the folder and download a different file again and repeat the process.

When I try to delete the contract - I get the message “The Process cannot access the file because its being used by another process “pdf” file”. The bot is able to delete the pdf for first 2 times but after that I see this error.

I have looked at all the posts regarding this and tried them but nothing has worked. Studio version 2020.10.4

Can someone help me with this?
@supermanPunch @Yoichi @ppr @balupad14

hello @Sairam_RPA ,
From my understanding of your problem,
could you please try to kill process activity with process name property as “ACROBAT” Or mention as “AcroRd32”.
and i think you are converting from excel to pdf please you can see there is a box - “open file after publishing” , uncheck that box .
Now pdf will not open after getting converted from excel.

I hope I could help you,
happy automation :robot: .


Depending on the size of the files, it may still not be possible to “close” the PDF.
Try putting a delay or killing the PDF before running it again.


I am not converting from excel to pdf. I just download a pdf document.

In the kill process in the screenshot I have added “AcroRd32” but it dint help.

I tried adding the delay and also kill pdf. It dint work. You can see the screenshot that I added

Are you killing the right processes?


Hello @Sairam_RPA

Can you do the Kill process after invoke method activity.’

I hope inside the invoke Method again you are utilizing the file. So plz do as suggested and update here.

I tried that and it still dint work

Yes I am. In the kill process I am using “AcroRd32”


I was able to resolve this Issue. It took me some time.

  1. Bot was uploading a pdf file to a website to check if the pdf file is valid or not.
  2. What I did is I refreshed the webpage after bot uploaded pdf and Bot got the output.
  3. Then I killed pdf application after the browser refresh.

This solved the issue. I think we have to look at the whole project and see where all we are using the file and try to handle.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.