The Problem with click list item

I want to click the list item,and i can’t click it success.I use the type default and type AA,then i can’t select the item i want.Then I use Type UIA,I select the item success,but when i run it,it failed.Then i tried Type Into Activity and it failed.Then I use Click Image Activity and it also failed.I use the broswer type is IE,because the page i want to automate have some bug on the other broswer.What else way i can use??

Hi @HuaiYe

Have you tried with ‘Select Item’ Activity.


@suraj.setty ,i tried it.There some error thrown.
Select Item ‘searchMSG’: Cannot select item. It was not found among existing items.
TIP: Some combo-boxes delay load items until its dropdown is expanded. Try to simulate a click on control prior to selecting an item.
Before the Select item Activity i use the Click Activity to simulate click the list to expand.

Try Click Activity with Double Click on Element. And if it still not works Than you can use Click And Click Text Activity to Select Element from Drop Down.


Hello @HuaiYe

Is it a web application? If yes, can you inspect the dropdown and check whether it is of type select or not.

If it is selected, then you can use select item activity. Also, check whether the item in the list and the value which you are passing are an exact match.

If there is any extra space or symbols please remove them and give them a try.

you can try with click and try to change the offset it may work in that case