Problem with a click activity on the item in the drop down list

Hello. I have a desktop application, and I need to click on the specific item which appears in the drop down list of many items. The Type into activity doesn’t work at all. IN the attached window I do Click on the combo box first, and all the items in the drop down list come up as expected. However when I do another Click activity on any item the drop down list immediately collapses, and the actual click on the requested item from the drop down list doesn’t work. I can easily select it and it’s highlighted in the UI explorer, and I see that this is the correct name of the item.
Please advise if there is an alternative way to click on the item in a long drop down list.

Hi @MichaelK

Can you try with Set text or select item activity

Best Regards,
Naveen Ch

@MichaelK why not use a “select Item” activity in order to select a value from the drop down?

Hi @MichaelK

You can try two different options. You can either use Select Item activity to select items from the dropdown list. or else, you can use the Click Activity with a proper selector to perform the click. In both options, make sure you have a good selector… and If possible, try to enable Simulate Click option if it is supported by your application…

Let know if that doesn’t work for you!!

Thanks
Lahiru

1 Like

Hi. I tried “Select item” activity. It selects the correct item and highlights it in the drop down list. However immediately after it clicks on the different item in the list. Not sure what to do about it.

Select item works in a sense it selects the correct item in the dropdown list and highlights it a different colour. However immediately after it clicks on the different item in the list although there is NO click activity. Exactly the same happens to the Click Activity. It selects the correct one initially, I can see it if I make the delay after for a few seconds, and then clicks the wrong one in the list. Cannot understand why is that. Simulate click doesn’t work at all - just nothing happens and the error in the Studio comes up.

Can you post the workflow please?

I worked it out in the end. I just sent the “enter” key to confirm the selection of the item. Initially it did not work however by trial and error I figured out that “Activate” checkbox for the “Send Hotkey” activity must be unchecked. Please see the workflow enclosed.Select_From_Drop_Down_List.xaml (8.1 KB)

1 Like

Hi,

There are multiple ways to do that but in past I have faced similar issue back to the point you can use “Select item” activity, “Type Into” activity or you can click to the drop down and then select the item which you need.
Hope it helps.

Thanks!

Lahiru, I tried the Select Item, along with the Send Hotkey of Enter, it worked perfectly trying to save a Publisher document as a PDF. I also attempted the same action using the Click which did not work until I used the Simulate Click property, as you suggested. I am still confused as to why, would you be able to provide more insight as to why exactly Simulate Click works?
MaryB