Terminal Session OuptutConnection is null

Hello, I am trying to pass an output connection of Terminal Session as argument between many workflows but the problem is the outputConnection varibale is null.

this is the log of the activity TerminalSession
{
“message”: “OPEN AS400 Executing”,
“level”: “Trace”,
“logType”: “Default”,
“timeStamp”: “16:19:56”,
“processVersion”: “1.0.1-alpha.1”,
“jobId”: “9aad2eab-1b55-4d76-a415-3139331b0a78”,
“robotName”: “DIOT-NT\ARAZGALLAH”,
“machineId”: 0,
“fileName”: “Test”,
“activityInfo”: {
“Activity”: “UiPath.Terminal.Activities.TerminalSession”,
“DisplayName”: “OPEN AS400”,
“State”: “Executing”,
“Variables”: {
“DT1”: “”,
“CONNECTION”: “”
},
“Arguments”: {
“ConnectionString”: “{‘AttachExisting’:false,‘ConnectionType’:1,‘EhllBasicMode’:false,‘EhllDll’:null,‘EhllEnhanced’:true,‘EhllFunction’:‘hllapi’,‘EhllSession’:‘A’,‘Host’:‘192.168.1.71’,‘Mode’:1,‘Port’:23,‘Profile’:null,‘ProviderType’:5,‘ShowTerminal’:true,‘TerminalType’:1}”,
“DelayMS”: “1000”,
“TimeoutMS”: “50000”,
“ExistingConnection”: “”,
“ContinueOnError”: “False”
}
}
}

Then when I debug the varibale CONNECTION is still null

image

Help please :slight_smile:

Hello @Razman

Check for variable is there any variable with same name
Also check weather argument direction

Cheers :blush:

Hello @Ajju, thanks for the reply,

In the main workflow i opened a terminal connection
image

then I invoke another workflow

and in the second workflow I try to use the existing connection like that

image

but I got this error
image

and this the output of debug
1st workflow
image
2nd workflow
image

Regards,

@Razman

As i can see everything looks good…
I think duplicate variable is created
If not created, i am not seeing any other problems in the work flow which you created…

@Ajju
The problem is that outputconnection doesn’t return an object, may be because of the provider type of terminal session?

@Razman

Is it working in the main flow…if it is not working then which provider your using?

@Ajju

Yes it worked in the main flo, even if I copy and past the second flow in the main flow it worked too. I am using UiPath Internal as provider, but I saw this provider cannot generate an outputConnection. :thinking:

Hi guys, I am facing this same issue. I am using IBM Ehllapi. Did anyone solve this?

Please help… it’s bit urgent

same issue here everything works fine if all terminal sessions are in the same flow/activity but the minute I move one outside of the activity where the connection is created the existing connection was null. I was able to fix this by creating a second terminal connection variable and after making the connection I assigned the connection terminal variable to the second one created and then used that one moving forward and everything worked fine!

Likewise! When using the terminal session activity and trying to assign an OutputConnection, the variable/argument I am using has a value of “Null”. Does this depend on the type of database I am trying to connect to? I am trying to connect to a reflection for UNIX.

Hi,
I have the same issue, the TerminalSession variable is Nothing. Can we use this variable with IBM Ehllapi ?

Hi,
I had the same problem where OutputConnection in TerminalSession would return null. What solved my problem was I had to leave an empty Sequence inside of TerminalSession activity instead of deleting it:
image - returns null
image - works fine

1 Like