Table extraction, next button not working

Hi all,
I am try to extract data from [ACME System 1 - Work Items (uipath.com)]. I am able to fetch data only from page 1 even though I indicated next page.

When I disable “Modern Experience” , use classic and do the same its working(Able to extract data from all 9 pages).

My question is why am I not able to do the same in modern experience.
Solutions I tried :
I tried changing the selectors of the “next” button.

Thanks,
Abhishek

Hi @Abhishek_Dharmapuri

I tried just now. Actually its working perfectly fine for me in modern experience.
Give next to this ui element and check once.
image

@Abhishek_Dharmapuri
You need not edit any selector . works well without editing selectors too


just indicate this button

@Abhishek_Dharmapuri

What selector are you using for next button? Is it strict or fuzzy or image or a combination?

Check it properly

Cheers

hey @Abhishek_Dharmapuri
It should work fine actually


Just enable the “Extract Data From multiple page”
And indicate the next button
Below is the file where i tried and extracted all the data from table successfully
Test.zip (11.6 KB)

Hope it helps you!

Hi @Abhishek_Dharmapuri

Hope it helps!!

Hi @Abhishek_Dharmapuri

For Extract Datatable activity change the Input method property to Simulate and don’t check the strict selectors be it in fuzzy selectors itself.

If you are getting the same delete the activity and reassign the activity and indicate, and do the above modifications.
image

Hope it helps!!

Hi @mkankatala @Vikas_M @B_H_Akshatha_Pai @pravallikapaluri @supriya117 @Anil_G

Thanks for your response.

If I Use Chrome browser its working. Its not working with Edge. Even though I indicated on next button, its not taking as button as it did in chrome

Thanks,
Abhishek

Hey @Abhishek_Dharmapuri ,
Try giving an achor
i gave an anchor and it worked for me

Give an anchor which never changes when you move from first page to next one and so on

I have done this in Edge browser itself

Hope this helps ,
Regards,

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.