Extract Table Data is skipping first page of results

Hi! This is my first post, I’m so glad to be here and learning this program. I truly love working with this. I am however, having some trouble with extracting data from a webpage. I fine tuned my selector to span across multiple pages but the extracted data is entirely skipping the first page of results. I run this program to pull the patients MRN off a report, and the first MRN it pulls is from the second page of these reports.

I will preface this by saying I work in healthcare and while I can not share the actual webpage, I can share my selectors and certain screen shots. I will attach what I can below. I tried to search the forums for help with this but every search result was the opposite of what I was trying to do. I’m wondering if this boils down to my selector on the data table? Any advice or help would be GREATLY appreciated. I’ve been stuck on this for a bit now. Thank you so much in advance!

Screenshot of report layout:

My first thought is that it’s possibly the IDX value in the selector so I’ve tried editing the “IDX” value, removing it completely, using an asterisk instead and it stops the table from being created completely.

and just in case, this is my NextLinkSelector which has not given me any issues, it clicks through each page, but when it runs my sequence, the first page of the report is not applied

"<webctrl parentid='rvReport_ctl09_ctl00_Next_ctl00' tag='TABLE' />"

@John_Pazienza If you want to extract data from the application you can go activities directly instead of selector tuning. If you are using modern design check the below doc


If you are using classic design check the below one

I for some reason can not understand the modern activities and it never really works for me. I know it’s a learning curve and I will give it a try but for what I’ve built so far, my data extraction works as I intended it to, but its entirely skipping the first page of results.

I will give modern a try but when I try to make it dynamic, it fails every time. I have to spend some more time with it I guess.

Thank you

You don’t make anything dynamic. It does that for you. It sounds like you’re changing things you should not change.

Create a new project. Go into project settings and turn on modern. Start on page one of your data on the web page. Click the Table Extraction button. Click Add Data. Click the first column of the first row of data (not the header row). When it prompts you about adding all columns, just click Yes.

Now click the button at the top that says something about the Next button, and identify that button. Click save. You should be pretty much done. Back in Studio, for the activity it adds, you can click the hamburger (three lines) menu and test the extraction.

@John_Pazienza Please go through below one to understand how it works

Note: You need not to make any selector dynamic with the above one

Thank you for this. I appreciate the video, and I did give it a try but it is giving me a very hard time. The report I run is done once daily so the URL, the data, and information inside changes every single time. With the modern table extraction, once it gets to the second page everything changes including the parent ID so it will not progress past page 2 so I have to modify the selector to even get it to see page 3. It also will not stop at the last page because the next page button does not disable so it gets stuck in an endless loop. This is what I mean when I say it fails every time I try to make it dynamic.

In order for this table to perform like I need it to, I have to modify the selector in the same method as the non-modern otherwise it doesn’t work at all. I honestly feel like the modern makes this even more challenging for my purposes. As soon as I change the page, the ui explorer is unable to validate since everything changes. Would I have better luck pulling the report URL as a variable and passing that to my screen scraping URL? Regardless I will have to modify the selector to make this work. I’m just so used to the non-modern format so there’s a bunch of new fields I’m not familiar with.

I’m sorry to make this so complicated but the medical record system I work with is not very uipath friendly with this and it’s been such a headache to work with this. I love UI Path so much, it’s so powerful, but it’s also very frustrating lol I understand the concepts of what I’m doing but when applying it, nothing seems to work. Thank you for all of your responses and time to try to help me with this, it really is appreciated.