Syntax for OrchestratorFolderHierarchy When Using Studio Command Line Publish

I have a pretty straightforward question.

What is the syntax for speciying the ‘Feed’ parameter when using the OrchestratorFolderHierarchy option when publishing a project from command line.
The documentation doesn’t give any examples and all the ones I have tried come up with an error.

I have typed it as ‘Folder Name’ and ‘Orchestrator Folder Name Feed’ as thats what appears in the build menu in Studio. Both result in the same object reference error.
Can anyone help me with the correct syntax to specify the folder to publish to?

Hi @Jon_Smith

Can you please look into the below one?


Hope this will be helpful. Thank you.

@Jobin_Joy That is the exact same description as the documentation I linked already, just as part of a different article dealing with the mass update tool.

It does not help as I’ve already read the same and the screenshot you indicate is showing the target parameter, which is clear. I need help with the feed parameter when using OrchestratorFolderHierarchy

Can you please try with --folder ?

Thank you.

Are you just randomly guessing? Thats not the syntax, the parameter is --feed. There is no parameter of --folder.

I have used --feed “Folder Name” and --feed ‘Orchestrator Folder Name Feed’ using the --target OrchestratorFolderHierarchy

Absolutely not. I was trying to help you with my knowledge since the issue was unattended for last 6 hours. My knowledge might be very limited when compared with your expertise even though I happily tried on the query :slight_smile:

I totally understand that you are looking for syntax.

Here is the example I was talking about. This is for executing a process and I believe we can use the same (- -folder argument) syntax for publishing a project as well under specific orchestrator folder.

If this is not helping you. Kindly ignore.

Thank you so much.

Well it completely contradicts the documentation I originally linked and you linked as there is zero mention of using --folder and the execute command is using not only a different command but a different exe entirely so, to me, it seems abit random to try and connect two unrelated things like that, but ok.

Thanks for trying, but I think you aren’t the right person to help here.
Lets hope someone familiar with the exe I am talking about can help.

The below one is working fine on the first-level folder.

Thank you.

1 Like

That only works fine because you have a single folder with a feed. Add multiple folders and try uploading to a specific one, without the --feed parameter which you omitted it just uses the last selected folder in Studio from what I can tell, which isn’t very useful.

So I got the automatic notice to try to close this topic. Posting again so it doesn’t get closed and hopefully someone from UiPath can help with updated documentation.

Bumping again so this doesn’t get closed.
Any devs/admins. This is an open issue, your documentation is incomplete and I cannot figure out the command line syntax.

Please help.