StudioX - Context menu closing upon cursor movement


I’m running into the problem shown in the video below. I can’t use context menus in StudioX because they close when moving the cursor. Any idea what could be causing this ?

Context menu disappearing

Hello @ADragotoiu ,

What version of Studio you have?
Also, if you go to the Package Manager, you will get a chance to update the packages to the newest available versions.

I tried on my laptop, I have the last stable version of Studio (2021.4.3). The context appear OK, no issue as in the video you posted.


@ADragotoiu Can you share your screen resolution information? Specifically how many screens do you have, and what are the resolutions? Also, is this running natively, or is it running in a virtual environment such as Parallels or via Remote Desktop?

My initial guess is there is a bug at a specific screen resolution where the menu thinks the mouse has moved outside it when obviously it hasn’t.

As a workaround, once you click to open the menu initially you should be able to navigate it using the keyboard. Alternatively as an experiment, you could try choosing a different screen resolution. But knowing what your resolutions are before you try that would help us to try to reproduce the issue

Hi guys,

@wasea I’m running 2021.4.3 stable

@AndrewHall I’m running a dual 4K setup. Text scaling is at 150%. I’m running natively. I’ve tried the following until now: changing scaling to 100%, disabling one display, resolution to 1080, disabling adaptive refresh (gsync in my case). I’ve also tried running Windows in safe mode. Unfortunately, none of the above helped.

And to further detail, it’s just that specific type of menu/sub-menu that has the issue. If I for example right click on the canvas and open a context menu, I can navigate to the “Annotations” sub-menu without issue.


Thanks for sharing the details. We will investigate and hopefully can identify the issue and fix it.