Struggle to create new variables properly

studio
error
variable

#1

Hello. I’m not a native English speaker so I’m sorry for my English.

This is the problem I experience using both the Community Edition and the Trial version.

When I attempt to create a new variable using the variables panel at the bottom the program begins to lag, freeze and I end up closing the app with the task manager. It happens everytime I do it via the variables panel.

If I use an object and try to create a variable in the properties of the object the result is the same. It simply freezes and I can’t keep using it.

If I press Ctrl + K to create a new variable then nothing happens, meaning I have no any reaction as if I pressed nothing.

The only working way is to press the “Create Variable” button at the top menu. But here’s also a trouble. If I create an integer value or an array data then in the variables panel it shows that I created a variable of “Generic Value”. This is strange. I can only create a string or a boolean variable properly. I can’t change the variable type as once I click anything in the variables panel I get lags and freezes.

My system is Windows 8.1.

Is it possible to fix it except for reinstalling the whole system?


#2

do you have any language pack set as default and display language and recently updated the dotnetframework installed?


#3

Excuse me, but I don’t get your idea. Could you please explain it in details and tell me how to check what you mentioned?
I installed the program without any additional options so the basic language was English and so is it now.


#4

if its English then its fine, you have another issue it seems.
what Studio version are you using?


#5

It was “Studio 2018.1.1” when I downloaded the community edition and “Studio 2018.1.2” when it was the trial one


#6

Unbelievable but the problem has been solved by updating the .net framework language packs. Once I’ve done that the problem has been gone. I also had a problem with the arrows. I didn’t see the lines, it only displayed the ends of the arrow lines. This issue has been fixed as well.


#7

Hi!!!

I have the same problem that you had at first, but…

I have already installed UiPath Studio and UiPath Robot, but when I try to create a new variable to an activity with the variables Panel, the application (UiPath Studio, I mean), lags and freezes, without leting me changing the attributes. If I click on the activity, after a few seconds UiPath Studio “comes back” and I can see that a new variable has been created called “variable1”, type “GenericValue”, and I can’t modify it for the same reason.

I have search the Internet and I think that I have done all the steps properly and I have already installed everything (.NET versión and Windows updates).

Can you help me, please?


#8

I would suggest you to open cmd as an admin and run “sfc/scannow”. It will scan your system and return the log file where you can find what system files are corrupted. In my case it showed an error with a code referring to the .Net problem. So I checked the important updates and it suggested me to update the framework. I don’t know what is going to happen in your case but that’s what I would start from.


#9

I have tried it, but it says that everything was OK…


#10

Well I hope the support team will help to find out what’s the problem. I would like to know it too as yes in my case it was .Net but I feel like it can be something else.