Some odd things

  1. Sequence dont work even i’m 110% it should. I copy activities to new file(empty sequence in same project) and it works…
  2. Working with excel scope. No matter what I do I get message cant’ write since file is read only and no programs is using it! Reboot windows and all’s fine!?!

What Im doing wrong? Or are these some UiPath problems?


Try to add kill process, ProcessName “EXCEL” at the beginning of your workflow and see if it works

Well I didt have excel running.

@Pentti_Ristioja If you were using Excel Application Scope, With Read Only Property set to True and you were trying to perform a Write range or a write cell Operation inside the Scope. It won’t allow you to do so :sweat_smile:

:thinking: Well then simple reboot wouldn’t be enough… Usually UiPath works like intended.

@Pentti_Ristioja Are you using Write range or Write Cell in Excel Scope with Read Only Property Set to True ?

Append Range. Excel scope with autosave,createnewfile and visible which work fine as it should.

@Pentti_Ristioja Ok, Then that’s the right way :sweat_smile:

Hi @Pentti_Ristioja

Try with work book write range activity. If that also not help then try to close the work book using workbook output with close application activity. It should fix this. Lets us know if it worked.

the problem is you can try to read the file inside the excel application scope its little bit difficulty


Did you check if your excel file is read only, i mean if you have just opened the file from a webpage, like “Teams”, you wont be able to write into it, you have to download it and allow modifications, because it can be protected. To do so, go to your excel file, click on file, than informations and unprotect the file and try again.

Add kill process, ProcessName “EXCEL” at the beginning of your workflow. It helps a lot in this kind of issue. Because if your desktop is connected to a cloud like “One Drive”, it might be that the file is still in use or uploading.

Also check if the file is shared by multiple users, if anyone on the network is using it, you might have issues to write on it and save it.

Hope this clears things out :slight_smile:

1 Like

Ty all! Problem solved


Good to know! What solved your problem ? Mark the answer which solved your problem as solution!

1 Like