SMTP Mail Stuck on infinite loop

Hi!, im having troubles with SMTP send mail activity, the problem is that this activity gets stuck on an infinite loop never throwing error .

it gets ““Solved”” after i kill all the assistant or UiPath related services on windows and rerunning the bot via cmd.

my question is how i can solve this on the long term? i should need to reinstall the asistant or the studio? , or it is a bug that uipath is currently trying to solve?

i also tried upgrading Mail activities

Hey @Joacobracci

Could you please show the SMTP activity props you are using ?

Thanks
#nK

Hi @Joacobracci

Are you using the SMTP Activity inside a for each loop?

Please help to attach the screenshot of the flow.

Thanks

The activity works fine when i kill the process of the uipath assistant

1 Like

the activity gets stuck on an infinite loop that isnt asociated with the retry scope, the activity works perfectly fine when i kill the windows process of the uipath assistant

Only for the first time it works fine after killing ?

It works until i open the assistant

It’s a known bug from this activity. To fix that, follow the instructions on the link below:

Send SMTP Mail Message Sometimes Hangs And Does Not Complete

Setting a timeout may help !

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.