Infinitely stuck on Send SMTP mail Message Activity

My process send an email with execption screenshot using “Send SMTP mail Message Activity”, it used to work normally but lately it does not work at all, it just get stuck with no error or log

1 Like


Check the following:-

  1. the credentials
  2. if TO part has a proper string in your variable
  3. if attachment name and variable for the attachment name is correct and its extension is there in place.
  4. if there is change in the config file (in most of the cases, as we change the string values in config we forget to follow correct delimeter)

I am sure, there is a silly mistake. Please check above points and get back to us.

Thanks and Regards,

I did check all option and even unit test before posting (I did earn advanced rpa developer certification), evething looks normal to me.
This process run daily, it used to send exception messages but now it does not, last time I recive one was 2 weeks ago, also this is an attended process for my personal use.


So as I see, you mean to say that there is issue with send mail activity itself, and all the parameters and variables are there in place.

In that case, what you can do is, in a separate workflow, try to use send mail activity with test subject, body and attachment. This is to check if you system is connected to that mail box and everything is synced. We had such issue and the problem turned out that send mail activity could not connect to the SMTP Mail box. It was access related issue in our case.

We also had a production live bot and there was some access changes from the IT team and then our activity used to be stuck without any trace. Once access was granted, the activity ran fine and process was executing as expected.



I did create an empty workflow with only Send SMTP Mail Message Activity filling it’s parameters with hard code values, still the same problem.
I am able to send SMTP mail with the same parameters in the same environment using python.



Based on what you said, parameters and connection looks fine.

Lets wait for our forum folks to come up with something on it.


1 Like


Did you tried to debug it. As you can get some information from debugging it , even it works fine without any warnings in debug mode then their might be problem with your input parameters that might be wrong or null.


Hi @Vish2148,

Yes I did, but I couldn’t get any helpful information, as for the parameters, I was able to send a mail using them in a python code therefore I am sure that they are right.


1 Like

@YAZIDI, @Vish2148

As I checked from my side, it’s more of the part where UiPath activity is not able to establish connection with SMTP server. Need to find a root cause for the same.

Can you please try to connect to some VM where you have studio and try to make connection to SMTP server?

Hello @hacky,

Today, I run some tests (the same tests as yesterday) and it work normally, I was able to send the mail and the Activity log error when something is wrong. But as I continue my tests it bugged out again no mail no log the robot is just stuck, just to make sure I did rerun the earlier tests which were successful again found the same problem.

As you said, I think it’s a problem of SMTP Activity, and the UiPath team should be notified.

Many thanks.


I guess you mis-understood me, I didn’t mean that there is a problem with UiPath activity.

What I meant was that SMPT activity is not able to establish successful connection with SMTP server.

There could me many reasons behind it.

Thats the reason I asked you to perform the tests with from other instance of the studio.
For example, if your project is created and run in VM 1, then try to use another Studio instance (VM 2) of your companies network and rerun the process. I need to understand if SMTP activity could connect to SMTP server to perform the expected task when we try from another machine of the same network.



Sorry for the misunderstanding, as for the project, it’s a personal project which means that I developed it for my personal use on my personal machine. And for your question, I said in the previously that I run tests this morning the first few were successful afterwards it the same results(stuck in activity).



Just out of curiosity, about the tests that you performed, were they from your own local machine or some other machine?

Because my point of trying it out from other machines was to understand if the connectivity can be established from a different machine in the same network…

If you are trying the use the same activity from the same machine, and still the SMTP activity is not able to connect to SMTP server as a whole, then creating a separate workflow and doing the same thing would not help.



You probably didn’t get what I mean:
Earlier this day, I performed some tests(test_01, test_02, test_03) on the same machine in the same network as follows:
+Test_01: success
+Test_02: success
+Test_03: fail
+Test_02: fail
+Test_01: fail
+Test_01: fail

Hi @loginerror, could you please lend me a hand to resolve this issue. love your nickname by the way :wink:!


Any chance something is rate limiting your access to the server?

Hi @loginerror,

I don’t think so, because I am able to do it with python.
the problem is not if the email is sent or not, the problem is that the activity do not timeout in case of an error, and the process get stuck infinitly.

Do you maybe have a chance to test this workflow on another machine to rule out any potential issue with the Robot service installation?

If it is the Enterprise edition, it might be good to contact our technical support.

If it is the Community Edition, then issues with workflows getting stuck are often related to the robot service not getting properly initialized after the auto-update.

Yes, still the same problem.
I am using a Community edition, so is there a way to properly initialize the robot manually?

It is just an idea, and normally a computer restart should do the trick.

If you want to check more, you can check the path of the robot service via the Task Manager. It should be running from the latest folder: