Sharepoint online get file

Trying to switch from Sharepoint on premise to online. Using the same credentials and activities but changed the Sharepoint Instance Type in the Sharepoint application scope.

Now during debugging I get this error on the first “Get file” activity:

Get the company file: Access denied. You do not have permission to perform this action or access this resource.

The strange thing is that if I use ignore and steps to the next get activity it works well and the file is downloaded. I have tried switching places for the two activities, and the first one fails and the second one succeeds. This is also true if I add another “dummy” Sharepoint activity in front of the two that fails. When clicking Ignore and stepping forward, both of the activities Get file work.

Testing connection is working and also as mentioned above the two files are downloaded at some point.

Any ideas?

Studio 2019.10.3
Activity package: UiPath.MicrosoftOffice365.Activities 1.3.0

my bad, activity package is: UiPathTeam.SharePoint.Activities 1.5.2

Anyone else experiencing the same issue?

@RayJay did you ever find a solution to this? I’m having the same problem.

hi i had this issue, and solved by changing the url and the path as below.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.