GetListItem Activity in UiPathTeam.Sharepoint.Activities

Hi,

Im able to download and filter the files in Browser. Also I could get the expected results for the below mentioned queries from SMART CAML.
“” +
“” +
“”

“” +
“2016-01-02T14:45:26Z” + “2020-10-15T13:19:10Z” +
“”

“” +
“2016-01-01T00:00:00” +
“2016-12-30T23:59:59” +
“”

But when I use the same in GETLISTITEM Activity with the same creds, its resulted with the below error.
Get List Items: Access denied. You do not have permission to perform this action or access this resource.

URL I have used in Sharepoint Application Scope:
https://adobe.sharepoint.com/sites/Compliance Reports/”
List Internal Name:
“Shared Documents/Org Level Access Approvals”
The Complete URL:
https://***********.sharepoint.com/sites/Compliance%20Reports/Shared%20Documents/Forms/AllItems.aspx?viewid=a222c7d6%2D6d58%2D4328%2Da978%2Da917a93cb7b4&id=%2Fsites%2FCompliance%20Reports%2FShared%20Documents%2FOrg%20Level%20Access%20Approvals

image

@radu_bucur @Cesar_Cotom, Can you please help me, if Im missing anything here or Do I have to modify my sharepoint permission level to “Member”?

It would be great, if you can send me an sample xaml file.

Attaching Queries as screenshot:

Just to update you that the Test Connection is success and I could get the “Get Children Names”, “Get file Activities” results as expected.

Hi could you please share the solution here? I am facing the same issue

Hey Jibin - Were you able to get a solution

Hi,

I know this is a late reply for your post, but maybe this can help someone else looking for the same solution.

I had the same error on GetListItems but only when running in debug mode.

Try to put Get List Items activity in try catch, then in catch section copy the same activity. The ideea is to retry one more time the activity after the error.

It worked for me.

When you fix something you should always update the forum with the solution. Stop making this a common theme on the UiPath Forum.

Just adding to this, if this works, it would probably be better to use flow sequence and check the content of the error message contents or keep track of the number of times the catch sequence executes. Otherwise it will never stop running.