Shared Drive_Uipath Orchestrator

Hi All,

I have an issue while running my process with orchestrator. We have our project saved in Shared Drive. i have situations like saving excel to shared location and writing outputs into it.When i run my project through Uipath studio, its working fine.But if i publish it to orchestrator its not writing or saving excel in shared drive but the remaining steps are executing fine.

Can anyone give me a solution related to this please
@vvaidya @Palaniyappan @badita @vikaskulhari

1 Like

are we getting any error or is it not simply writing
Cheers @Satish_Ch

Hi there @Satish_Ch

if it is an unattended bot and it is not able to save then have you checked sharing option (is the sharepath accessible from the BOT ID) ?

It should be configured with all the read, write edit rights and shared.

i am not getting any error, if i run through Uipath Studio.Its working Awesome. But issue with only orchestrator.

1 Like

is it completing the process or getting stuck at the place where excel is written
if that gets completed then we need to check with the folder path of the excel
if that gets stuck then we need to look into the process
Cheers @Satish_Ch

Its not unattended,bot type is Studio.

And how can i check configuration of shared drive to write and edit?

choose the robot type as unattended and try once
and also ensure that you were able to update the file or create a new file in shared folder

Cheers @Satish_Ch

Tq. Ok let me try once

I have tried by changing type to UnAttended still no solution. And i am able to create file in shared folder but not with BOT.

How to give access to bot for writing and editing in shared folder.

its getting completed. I dont think we need to change folder path of excel as read range path also, for it its working fine only for writing its not working.

As read range path is working in the same process

I think there is a problem with something else. Is the path you are accessing too long?
If that is the case uipath should throw an error, worth the check.

Is there a possibility that some other bot is also accessing the file? Some cases it will be able to read but not actually save the changes.

Maybe there is a workaround, copy the excel file to the local system make required changes and then replace it with file transfer protocol.

Get back if issues still persist.

Hi Satish,

Please check the path of the files you are writing too.
Because what happens is, if you are running from studio relative path also works. But while running the bot through orchestrator we have to pass absolute path only.

Hope it helps.

1 Like

did you try to save this folder path in “Assets” (orchestrator ) and try to retrieve ?

@Satish_Ch, sounds strange however @Palaniyappan, @Raghavendraprasad has already provided you a couple of solutions.

I guess, there is some issue either with share drive or the path. I would suggest you please check below steps:

  1. Check the data table if it is not empty. Add logs to understand bot behavior.
  2. Bot ID should be able to access the drive.
  3. try to avoid mapped drive path(F:). rather use network path (\networkip\folder1\subfolder1)
  4. Check with both Excel Application Scope and Workbook
  5. Still doesn’t work then treat the excel file as a database


So let’s do one thing
I think this happens because of multiple of generic access level restriction to the folder
—I would suggest to create a local folder in the machine where this process is ran and create the process in such a way that first the file is created and stored in that local folder
—later we can use MOVE FILE activity and mention the source path property as the local folder with file path and the destination as shared folder path
Make sure that the shared folder is synced to your machine where this process is run

I hope this would work for sure
Kindly try this and let know for any queries or clarification
Cheers @Satish_Ch

I dont know how to check bot id access,can you please let me know where can i check bot id access ?

Thanks man.This worked for me.

1 Like

Thanks to everyone for quick responses.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.