Unattended robot is not writing any excel

Hi all,

I have uploades a process to Orchestrator and robot is not reading or writing excels. I know that I must put the whole route folder inside excel activities, and I did it, but it is not doing the activities.

Do you know how to handle this?

Thanks :slight_smile:

You’ll need to provide a lot more detail I think. This could be a number of issues. In my experience no output typically means it’s failing outside the activity itself (if the path was invalid, I believe the Excel activity would throw an exception).

  1. Does the code work fine when run locally/from studio?
  2. Do the Orchestrator logs confirm the robot is running?
  3. Do the logs confirm that the .xaml for with the Excel components is being accessed?
  4. Add logs to check what paths are being used for the Excel scope.

Hello @Bobby_J ,

In studio it works, and from Orchestrator also because it loggs in inside an application we use. I have checked the “project” file generated from studio and appears Excel activities…

How can I check the 4th step?

The logs from each bot run should be accessible from Orchestrator, and exportable to Excel. It should contain all the information that normally appears in the “output” in studio.

1 Like

I have found that when I publish the project is saved here, instead where I have everything…

How can I change it?

Many thanks! :slight_smile:

I believe you can’t change this folder.
All processes accesible for a robot are saved in this folder: /.nuget/packages

Can you give us a bit more details how you are reading the excel file. (A screenshot of the activity maybe? and the filepath you are trying to use?) Your project stored in a different location shouldn’t be an issue.

1 Like

This is one of the excels files:


Have you checked if the robot account has access to this filepath?
If it is a network path, maybe the letter is different?

Do you get any error in Orchestrator when you try to run this part?

1 Like


I have found the solution. Robot couldnt continue because of a wrong variable and it didnt write. Now it works!

My apologizes!


Glad you solved it! Log messages are a good practice to try to limit the pain in troubleshooting. I always thought they were annoying to add in, but I’ve wasted days figuring out bugs…

1 Like

Yes you are right! I thougth the same as you! But now I see them a good practice!