SFTP Upload files Permission denied

Hye All,

I have problem using Upload files in FTP activities. I seems to get error when I want to create a new directory or upload a folder.
This is the error:

RemoteException wrapping System.AggregateException: One or more errors occurred. —> RemoteException wrapping Renci.SshNet.Common.SftpPermissionDeniedException: Permission denied

I can upload files successfully using the upload activity.
And also there’s no problem in permission as I’ve tried uploading and creating files and folder using FileZilla without issue.

I got an error when I specify a folder in the ‘Local Path’ instead of files.
I also tried putting a new path in the remote path, Which mean in the ftp only got ‘/RpaFolder’, I added ‘/RpaFolder/NewFolder’

Both got same error.

Appreciate if you can help

Hello @Eizzuddin_Zaid!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi @Eizzuddin_Zaid

Would you be able to reproduce this error on some publicly available FTP server and provide us with the sample project?

It would help a lot.

Please also be aware that the FTP package is supported, but updates might come slower due to the fact that it has been ‘outsourced’ to our Community via our Community Activity GitHub repository:

This also means that, if you wish, you can look directly into the code to try to figure out what is not working there.

I’ll mark this topic with a #pr-welcome tag for anyone wanting to help you out.