SendHot Key throwing error

encountering error on sending hot key.

Simple sendhot key is throwing the automation

are you inside a VM?

no VM involved.
I have a sequence with just send hotkey activity
with Win+R
thats about it

so you are running this process using the studio and get that message? IF so, i never seen it happen… Could anyone been trying to remote connect to your machine?

No remote, no Citrix, no VDi involved.


  1. Open UIPath Studio
  2. Add sequence, Added Send hot key
  3. select windows key and “r” key
  4. hit f5 to run
  5. got the error.

thats it. as simple as it gets.

@hsarva Can you indicate the Desktop window and Check ?

Hey ,

Try Start process and give input as “explorer” and local path you wanted to open …in spite of Send hot key because Send key require some attach window or attach browser for processing .

it will work for sure !!

Kindly use Hot key inside attach window then it will work :slight_smile:

Is sendwindowmessage property enabled

Please add the application specs in container.

Example:- Use Attach Window

try Send Hotkey within Desktop Recording :smile:

yes it is

I have tried the same and its working fine
please check below workflow is it working at your end
Sequence.xaml (4.3 KB)

following the

  1. reset all the changes i made earlier
  2. disconnected robot from orchestrator
  3. connected again
  4. restart the machine

solved the issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.