Send SMTP Mail Message not working and getting stuck

Hi all, I previously built a workflow to send out emails using the Send SMTP Mail Message via Gmail. It was working fine for the last few months until today. Now it just shows execution started but it just sits there with no error.

Currently using port 465 on smtp.gmail.com

Anyone know if there was an update on uipath or gmail that might be disrupting this?

1 Like

Hello @trigeki ,

No, still the Gmail uses port 465. Can you please check your Gmail setting?

for using the Gmail using UI path you need to turn on the allow less secure app permission over there.

please check through this link Less secure apps & your Google Account - Google Account Help

If this doesn’t work for you. Please share your workflow over here.

Regards,
Venkatesh R.

go through this video for turn on less secure apps

just turn on it should work

I have the less secure apps turned on. It was turned off recently but I turned it on and it’s still not working. Someone I know was able to get it to work for about 20 runs through the csv list of email but then it stops. Please see attached workflow. I put a dummy name for the email

Email.zip (2.0 KB)

@trigeki now I have made the simple change of changing the delimiters as a Tab. And i was able to send email for 3 different people.

Regards,
Venkatesh.R

Not sure if the version means anything but I’m running 2020.10.6.

I tried updating the delimiter from comma to tab and it’s still not working

Yes please update the packages, studio and run

Updated the packages and ran in debug mode. I got the following error: “Send SMTP Mail Message: Timed out while waiting for Mail Service to connect”. Using the same host port and server in the workflow that I sent over. I have the less secured app setting on google turned on.

Can you please share the error log message

Has something changed on your network, like a firewall now blocking that port?

@trigeki


Can you please check your gmail setting with this list.

Not that I’m aware of, using the same vpn as always