Send gmail with Send SMTP mail Message not working

I am trying send gmail message using the Send SMTP mail activity. I have configured everything and it was working fine until it doesn’t. It happened yesterday, i tried this morning, it worked for 10 minutes, then broke again.
The exact issue was when the process was running, it would stuck on the Send SMTP Mail Message activity. The process would still be running, and there’s no error messages, it just never sends the email, and does not move on to the next activity.

I am confused because i tried the same activity with the same configuration on the a different machine, and it works.

Please help!

@siming

Hey try to cleat you uipath cache

C:\Users\siming\AppData\Local\UiPath.cache

@siming
did you enabled the gmail setting for sending an email. Before running your Uipath script you have to enable the gmail POP and SMTP setting from your google account otherwise this will block for sending an email.

yes i did, as i mentioned, it was working but all of sudden stopped, no setting was changed, no configuration was changed

do i delete the cache file?

Yes, delete all files in cache

i deleted all files then restarted Studio, still, did not work

@siming

Can you check your packages once and update it if required.

Packages are updated before i started running into this

@siming

Can you compare mail packages version on working system and non working machine.

I had an older version on the working machine, it was working; I updated the package in the working machine, it still works;
I had an older version on the not working machine, it did not work; I updated the version on the older machine, it still did not work

@siming

Well, let’s do one thing.
You run bot and get windows event logs from windows

Okay, and do I upload the file here?

@siming

Just copy paste and update

I couldn’t get the event log, I looked at it and was trying to figure out what happened, and nothing related to UiPath was on there. Also, yesterday around noon it started working and sending out email without any issue, and i thought maybe somehow it magically was fixed. Then this afternoon i am still stuck on the same place.

1 Like

I also meet the same issue, the uipath does not print out any error and the program is stuck on sending smtp email action

Same here … I tried everythin: even disabling my own firewall ( Norton ) , to no avail . Maybe Google changed something that broke the UIPath library?

The same here. SMTP works on different machine with 20.4 version fine, on server with 20.6 does not work with deleted cache, updated packages, folder exclusion. Any other ideas how to proceed?

Has anyone found a solution yet? I had it working for a couple weeks now stuck back on this again. Pleaseeeeee help!

I solved the issue by reinstalling studio. Although the same version 2020.6.0-beta.93 was re-installed, it suddenly started to work. I tried to create test project with smtp activity and it works well. So I recommend you to try it this way. Hope it helps.