Send SMTP Not Working for the Gmail

Dear Folks,

Send SMTP activity throwing an error:
“Send SMTP Mail Message: 535: 5.7.8 Username and Password not accepted”

I have entered 465 as port number and server details as with proper logon details, Along with this I have enabled Less Secure Access on my Gmail Account.
2 step verification been turned off…
SecureConnection Set to “auto”

What could be the issue here…?

Any solutions or alternatives will be appreciated…

Can you try below:
Generate App Password with Google account and then used the generated app Password in-place of actual password

Hey Akash,

Generating App Password is not supported for my account (office gmail).

Have you visited this link to allow your device to connect to your Google account?

Have you tested with the port 587 instead?

Does it work if you run the Powershell commandlet below?

Send-MailMessage -To "" -From "" -Subject "Your message subject" -Body "Some important plain text!" -Credential (Get-Credential) -SmtpServer "" -Port 587

What version of UiPath.Mail.Activities are you using? Can you try with 1.6.0; 1.7.2; 1.12.3 ?

Hey @ptrobot

I have tried with 587 port, not working…

I did try now by running the PS script, got the error

It did ask for the username and password, I have entered the system sign in credentials…


You need to change the email adresses in the command line also to your own and also add -UseSsl.

This is how it looks on my PC:

Yes I did, it is throwing the same error, I am running from my org email…

Do you have an IMAP option you can enable on your org email?

Yes I have enabled it…

Ok, then I’m out of ideas.

I believe it works, if i get the option for generating the App Password…

I came to know little lately,

The company has restricted for Sending Mails through the Bot so the code was not working, hereby closing the topic…

Thank You

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.