Send Hot Key CTRL+A Issue

I am trying to use the Send Hot Key activity “CTRL+a” to clear a UI text box. However, it is not recognizing the command. It will not highlight the text. It just moves on as if it did it. I use a “click” activity to “activate” the test area followed by the “Send Hot Key” activity and nothing happens. I even used the “type Into” activity to try and clear it that way and it does not work either. I need to delete the text from the text box area.

Any issues with version 20.4 for the Send Hot Key activity?

image


Can you use type into then check “Empty field” = True?

1 Like

2 Double quotes should supplied in the text field.

I have tried that with double quotes and it still does not work.

@PWilliams

Please try checking the Empty field property of type into activity. I think it should work then.

Thanks
Hope it works!!

1 Like

That did not work as well. I’m wondering if it is the web app itself.

  1. Use a type into activity for that text box
  2. Type “[k(end)d(shift)d(home)u(shift)u(home)]”
  3. Use send hot key to delete the text.

Text in point 2 is responsible to select all text.

Thank you, Omar. I tried it and it did not work. Do I have it setup correctly? It acts like it did it and moves on to the next activity, but it never highlights the text. I can use the same activities in other web apps and it works. Does the added screen shot look correct to you?

@PWilliams

Please check the selector of the element. Share it with us also!

Do share selectors of 2 of the elements above and below the Text field!

Thanks

Dear, to make sure that your work is perfect, please use native citrix recording as below
image

then delete the copy activity and replace it with send hot key, but make sure the selector of the send hotkey is the same as previous activity.

1 Like

@PWilliams

Please check the selectors after doing the same process to reach the webpage, maybe some value in the selector is variable everytime you reach the page, that’s why!

1 Like

Are you suggesting the selectors are changing each time it reaches the page?

@PWilliams

As per your post, that it is not typing or selecting the text using your hotkeys thus , most probably it is not able to find the selectors of the text box.

Maybe the selectors of that box are dynamic, that’s why!

Please check the selectors after of the text area after making two separate instances!

Do share here!

Regards
A

I’m not seeing any difference. Im wondering if its the web app itself. Its an older web app that emulates in an IE8 browser and uses ActiveX controls in the web pages. That may be the issue. Thoughts on that?

image


Use Simulate type into, if you have checked that option by default it will empty the text field before writing any text into it.

Dear,
Please do more analysis for the selector. in UIPath, everything will work but you need to identify the way :slight_smile:

Hello, I have tried the Type Into activity as well and it does not work. For some reason it will not empty the text field.

Then give a try with set text as well. Hope thwt will help you…

I have tried that as well. :slight_smile: