Selector issue

selector

#1

Dear all,

About issue, please refer to the attachment.
I tried re-install, but issue is not resolved.

Scenario:Desktop Recording/ Creating activities

Steps to reproduce:Desktop Recording/ Creating activities

Current Behavior: Selected too large element

Expected Behavior:Selected each element

Studio/Robot/Orchestrator Version:Studio 2017.1.6435

Last stable behavior:Selected each element
Last stable version:Studio 2017.1.6435?
OS Version:Windows 8.1 Pro with Media Center
Others if Relevant: (workflow, logs, .net version, service pack, etc):Microsoft Office 2007 Suite is updated automatically in last weekend(September 3rd, 4th).

Best Regards,
Soshi Miyata170904_UiPath_Selector_Issue.xlsx (805.5 KB)


#2

did you try with uiexplorer to see if you can find elements?
if you try on another application, lets say notepad, does it work?


#3

I checked.

Would you like to see attached file and how to resolve it?

It seems selector became strange from last weekend.

170905_UiPath_Selector_Issue.xlsx (508.4 KB)

Best Regards,
Soshi Miyata


#4

hello team I am facing selector issue in my code. in which I am unable to find a unique selector. please provide me any solution.

Thanks & Regards,
Jyoti Gadekar


#5

Hi @jyotig,

Try uiexplorer to get the the exact selector.

If you are again facing the same problem please add the parent tag also to get exact one.

Regards,
Arivu


#6

Hi Team,

I have tried
UIexplorer to get the unique selector but it’s working only for the first time, But I want to click on that particular image into loop. So while I am trying to click on the image for the second time it is not working.

Please suggest any solution.

Thanks & Regards,

Jyoti Gadekar

Intelligent Automation & Technology


#7

If your selector is dynamic, you ll need to make it more reliable from the activity


#8

UiPath workflows are not able to integrate with the UI of RDC and other applications. The selectors were working for the past 2 months and stopped to work last week. This is the case with most of my other team members working on different applications.

We are unable to remap the selectors as the Studio/UiExplorer is unable to detect the UI elements. Is there a patch or fix for this issue?


#9

if they stopped working last week then you ll have to tell us what changed at that point - either with the application or with studio/robot
i ll need more details in order to help here.