Screen calibration off, robot clicks offset


#1

Scenario: When pressing indicate on screen, the small selection screen is offset by 400px north east and the higlight boxes as well. When the robot is run the robot clicks on the offset spot instead of the button it’s found and trying to click. I have a dual screen setup, both screen with same 1920x1200 ratio.

Steps to reproduce:

Current Behavior:

Expected Behavior:

Studio/Robot/Orchestrator Version:Currently 2017.1, but problem has been on all versions

Last stable behavior:
Last stable version:
OS Version:
Others if Relevant: (workflow, logs, .net version, service pack, etc):


#2

Hello,

can you please try to relocate the uiElement with the UiExplorer?

also, can you please let us know if is this happening with other activities in other windows? Which program are you trying to automate.

regards,


#3

Same with UiExplorer. My screens have different resolutions, which I believe is the problem. This is happening with all programs, at the moment I’ve been automating internet explorer. the offset varies, now it was about 100 pixels northeast. I have to navigate to the elements using the small selector screen instead of trusting where the mouse is.


#4

oh I see, so you are referring to the elements by using coordinates, seeing you are graduated, or at least part of the group here, I guess you can only reffer to the element on the screen by using the selector asociated with it. I had the same problem using two screens but the image was only for reference, and yet it was moved from the target the activities worked just fine. pardon me if you know what you are doing and you were only indicating the error. :slight_smile:


#5

Even with selectors the robot is confused about where the mouse is. I think I’m not able to explain the problem eloquently enough.


#6

Not at all my dear friend, you explained correctly, I know it might sound “IT” but can you please try to restart your computer LOL… Just kidding, now seriously try to resintall UiPath downloading the latest version.

Thanks…:slight_smile:


#7

Hi,

If you have a multiple monitor setup check that you have same resolution and scaling (size of text) on both monitors.
If you have a retina display on your laptop/desktop, try to set the scaling (size of text) to 100%.

Note: After changing the scaling setting you must sign out from your account so the changes take place (Windows also recommends to sign out after changing this setting)
Let me know if this solved your problem
Thanks,
Cosmin


#8

Yup, scaling was the problem. It keeps setting to 125% when I remove my second screen from the laptop. Thanks!