Scheduling UiPath tasks while using the Community version

studio

#1

Hi,

Recently I started working on UiPath to gain knowledge in RPA, I have created several tasks which involve from downloading excel file and then comparing it to another excel and getting missing entries as output all with the help of this forum and the youtube videos :slight_smile:

A few weeks back I thought of scheduling these tasks, found some videos on youtube using the Windows Task Scheduler but that wasn’t working for me.
Read the forum as well searching for this but found that you need Orchestrator to schedule tasks which requires you to buy a license.

If anyone knows anyone workaround being in this same situation and are in the learning stage of RPA.
UiPath Studio version: 2018.4.0

Thanks
Pratishthit


#2

You can use Orchestrator CE for until you are using it for learning purpose.

It must not be used for commercial purpose

See this

Thanks,
Prankur


#3

Thank you @PrankurJoshi, I didn’t know about that and after finding some guides I was able to move forward.
I set up the Orchestrator by creating a machine, uploaded 2 packages and created one process, after that I created one environment as well as one robot (development type), but this robot is disconnected all of the time and when I create a job it stays in pending state only.
How should I move forward with this? Do I have to connect the robot installed in my system to the Orchestrator, if so I am not able to find the Orchestrator URL to enter there.

Regards
Pratishthit


#4

You will have to connect your machine to the Orchestrator

image

Orchestrator URL Should be http://platform.uipath.com

If you cant see this on your system go to

C:\Users\User\AppData\Local\UiPath\app-18.4.0

and run UiRobot app then you will se Ui icon in system tray

Thanks,
Prankur


#5

Okay, great.
Completed this and now it says Robot unavailable (The machine key is linked to another machine) on UiRobot app which is understandable and once I publish a project it goes directly to the Orchestrator which is also great but on the Orchestrator it still says that the robot is disconnected.
Am I missing something?
Steps completed:

  1. Robot created and connected to the environment
  2. Machine created
  3. Package published and process also created

Regards
Pratishthit


#6

Machine key should be one what you got from Orchestrator, has you linked the same one?

Also, have you given Machine name, UserName and other info while Provisioning robot?

Thanks,
Prankur


#7

Yes, the machine key I entered was from the machine created in the Orchestrator.
And I have not provisioned the robot, I couldn’t find that option. Could you please provide some detail on that.

Thanks,
Pratishthit


#8

No its the same thing what you just did

can you show me the error or steps what you have performed?

Thanks,
Prankur


#9

Okay, I’ll mention the steps but might not be 100% sure about the order of completing them,

  1. Created a machine
  2. Created a robot using the machine and type as development (settings tab I didn’t change anything)
  3. Created an environment and assigned this robot in it.
  4. Created as you mentioned before I connected the robot to the Orchestrator, with the machine key from the machine created in Orchestrator and URL as http://platform.uipath.com/
  5. Published my project from Studio and created a process using this package while selecting the environment created before.
  6. Tried to run a Job after selecting the Process created above

I think this covers whatever I have done.

Thanks
Pratishthit


#10

Hello,

Me too placing for scheduling jobs using windows scheduler, if anyone worked before do share the steps.
As enterprise robot is to be purchased apart from studio so trying to avoid using orchestrator as of now.

Thanks,
Meg


#11

Is your robot says Status as Available?

What UserName have you used in Robot


#12

@megharajky Please take a look at this, Orchestrator CE is also available where you have 2 robots, but it is only for testing purposes.
This is what I’m using right now.


#13

No, it says disconnected.
And the Username is my PC name (in the Domain\Username field)


#14

I have worked on CE before but this is for client, that’s why I mentioned about windows scheduler.


#15

What does this mean?


#16

I tried Windows Scheduler from the videos mentioned on youtube, nothing worked for me, I think they removed the support for it but I am just a rookie so idk, that’s what brought me here haha.


#17

image
When I hover the mouse over Robot unavailable this is what comes up in the UiPath Robot app


#18

Can you please Click on Settings Icon image and show me what is there

And I hope you are the only one who is using Orchestrator alone


#19

Let me give a shot, if I achive will post here.


#20

@PrankurJoshi
image
Machine name is already entered and is read-only.