SAP Selectors problem

Dear Experts, Hope someone can help/guide me on this.
I am having problem with one of the selectors in SAP FB03 transaction. My requirement is to double click on the first line item and get data. I am doing this as shown below:

I have to double click on Item 1, and i am using Click activity, with selector as below, which is working fine for that document:

sap id=‘usr/lbl[2,12]’

However, for the different document, the same selector is pointing to Header "Itm’ Field.
When i re-indicate the element, the selectors are as below:

sap id=‘usr/lbl[2,14]’

How can i resolve this issue? I tried to use anchorbase with find element. However, Find element selectors also like that.

Please guide me. Thanks in advance.

Note: This doesn’t appear to be a table to get the index.

1 Like

Hello @vasu.anum ,

you can use CV Activities or Click Text activity.


Hello @vasu.anum, one work around I can suggest is use click image and select the first item. That worked for me during testing. I assume you would also need the next items on your list, so on the Display Document: Line Item 001 just use the down triangle to go to the next item.

Alternatively, you can also send hot keys Shift + F7 which is the same as pressing the arrow. After every click of the arrow, check first the status bar if you already reached the end of list.
If its the end of list, then its time to press the back arrow (F3) and process the next documents.

Hi @vasu.anum

The item you are trying to click is always on column 2, but the line is different from one document to another.
I suggest you use the UiPath.Core.Activities.FindChildren activity to get all items with column 2, then use UiPath.Core.Activities.ForEach<UiPath.Core.UiElement> to find the item with text=1, this is the one you want to click. Once found, break the loop because all elements are invalidated by SAP WinGui on Double-Click.

Please let me know if this works.

Best regards,



Hi @Pradeep_Shiv , Thank you, i tried that already and didn’t work because the selectors are same as like Click.

1 Like

HI @vasu.anum

When I am looking on your screenshots, I am a bit confused.

When you are opening FB03, you will see a nice SAP GRID table with all items, which you can easily and uniquely automate and press 1 item, 2 item and perform any activities you like
(see screen 1)

But in your case, you are navigating to Print Preview and want to perform actually the same stuff, open 1 item, 2 item and so on (see screen 2). The table on SAP screen 2 is so called SAP Labeled Table, which are for human-being looks like a table, in reality it is just a set of labels, this is also a reason why you see LBL[1,2].

I would suggest to work with table on Screen 1, where actually automation should be done.
Screen 2 - print preview has different business purpose.

Best regards, Lev

Hi @LevKushnir
Thanks for your reply. I am not on print preview screen. The screenshots are from direct FB03 t-code. The difference might be due to SAP versions. Ours seems to be SAP netweaver 7.5 version. If this is in grid layout, i could easily use data scraping or other methods. Thank you :slight_smile:


Just found one more workaround, in toolbar I have this button, which will bring me always in Editing of first position

once, inside the next screen, you can navigate with this:

Would this work for you?

Best regards, Lev

This is also not working as we have to select the line item before we click the ‘Change Individual line item’ button on the tool bar.
This is what i am getting when i tried to click that pencil button:


Thank you very much for your suggestions.


What about this approach?

When I am starting FB03 and entering the data, I have an option in menu navigate to the first item from the initial screen

Does it work for you?


Thank you @LevKushnir
This workaround is working. Appreciate it!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.