Running UIPath tests using UIRobot in cmd on Jenkins

Hi all,

I need some help here. Tried running UIPath tests(UIPath Version 2018.3.1) (Main.xaml) file using UIRobot in cmd in Jenkins(AWS server with Win 10 installed) and getting such error:

How user can grant an access for Local System in Orchestrator for Robot?

Has anybody ever faced with a similar issue? Been reading a lot of posts here but unfortunately still don’t know a solution.
Thanks in advance!

We have many topics with the same error @Ask

Can you check the username you gave to the orchestrator?

The problem is robot is running remotely on AWS Server. I’ve given my username and credentials in Orchestrator. And the user from screenshot it’s a Local system and is supposed to have all granted access. Local system doesn’t have any credentials in that case can I use it for unattended robot running?
Thanks

In that case, you need to create a floating robot so that you can connect to the orchestrator with your credentials @Ask. I haven’t tried with floating robot, but in this particular scenario, you need to run the floating robots.

Can you try that and check ?

Update: Well I tried setting up a floating robot.
It didn’t change anything:(